ОЧЕНЬ по информатике Написать программу каторая выводит таблицу значений функции у²+5Диапазон изменения аргумента от-4до 4 шаг приращения аргумента 1на экране должно быть выведено у(-4)=21у(-3)=14
Var a: array [1..10] of integer; i,max:integer; begin for i:=1 to 10 do readln a[i]; max:=a[1]; for i:=2 to 10 do if a[i]> max then max:=a[i]; for i:=1 to 10 do begin if a[i]>0 then a[i]:=max; if a[i] >0 then a[i]:=i; end; for i:=1 to 10 do writeln( a[i]); end. 1. Заполняем массив из 10 элементов 2 Считаем условно что первый элемент максимальный 3 В цикле начиная со второго элемента находим максимальный элемент 4 Осуществляем преобразования в цикле с учётом условия 5 Раз у нас задача на замену то осуществляем вывод массива чтобы просмотреть его элементы
Vyacheslavovna1108
05.03.2020
Var n,p,m,max1,max2,im1,im2,i:integer; begin Randomize; n:=347000; max1:=0; max2:=0; for i:=2017 to 2025 do begin p:=round(n*(2*random+1.5)/100); m:=round(n*(2.5*random+0.5)/100); if p>max1 then begin max1:=p; im1:=i; end; if m>max2 then begin max2:=p; im2:=i; end; n:=n+p-m; writeln(i,': n = ',n); end; writeln('Наибольший прирост = ',max1,', ',im1,' год'); writeln('Наибольшая убыль = ',max2,', ',im2,' год'); end.
Пример: 2017: n = 345558 2018: n = 349922 2019: n = 353532 2020: n = 356979 2021: n = 364842 2022: n = 371614 2023: n = 381020 2024: n = 389903 2025: n = 388485 Наибольший прирост = 11702, 2023 год Наибольшая убыль = 10701, 2020 год
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
ОЧЕНЬ по информатике Написать программу каторая выводит таблицу значений функции у²+5Диапазон изменения аргумента от-4до 4 шаг приращения аргумента 1на экране должно быть выведено у(-4)=21у(-3)=14
i,max:integer;
begin
for i:=1 to 10 do
readln a[i];
max:=a[1];
for i:=2 to 10 do
if a[i]> max then max:=a[i];
for i:=1 to 10 do begin
if a[i]>0 then a[i]:=max;
if a[i] >0 then a[i]:=i;
end;
for i:=1 to 10 do
writeln( a[i]);
end.
1. Заполняем массив из 10 элементов
2 Считаем условно что первый элемент максимальный
3 В цикле начиная со второго элемента находим максимальный элемент
4 Осуществляем преобразования в цикле с учётом условия
5 Раз у нас задача на замену то осуществляем вывод массива чтобы просмотреть его элементы