tanu0618
?>

Написать программу, которая запрашивает у пользователя значения трех целочисленных переменных x, y, z и находит значение выражения 8x+y-5z. Очень

Информатика

Ответы

Конычева-музей"260

program RED;

Var

x,y,z,d:integer ;

begin

writeln ('x=');

readln (x);

writeln ('y=');

readln (y);

writeln ('z=');

readln (z);

d:=8*x+y-5*z;

writeln (d);

end.

Объяснение:

alanatan5757

язык paython

x=float(input("чему будет равно x?: "))

y=float(input("чему будет равно y?: "))

z=float(input("чему будет равно z?: "))

gg=8*x

ggg=gg+y-(5*z)

print(ggg)

ruslanriad10
#include <iostream>
#include <cassert>

using namespace std;

void pie_price(int a, int b, int n)
{
assert((a >= 0) && (a <= 1000));
assert((b >= 0) && (b <= 99));
assert((n >= 1) && (n <= 1000));
double price = a * 1.0 + b / 100.0;
float res = price * n;
int kop = res * 100;
cout << "Rubles " << res << endl;
cout << "Kopeyks " << kop << endl;
}

int main()
{
int a, b, n;
cin >> a >> b >> n;
pie_price(a, b, n);
}
kazan-ugoop36

1-й Через "буферную" переменную

Пусть первое введенное значение присвоено переменной a, второе - b.

Присвоим некой третьей переменной (например, c) значение хранимое в a. Таким образом окажется, что одно и то же значение будет сохранено в двух переменных.

Запишем значение переменной b в a. Таким образом, мы "затрем" прежнее содержимое a, а значение b будет храниться в двух переменных.

Однако значение a не потеряно, т.к. заранее было сохранено в c. Теперь мы можем присвоить переменной b значение хранимое в c.

В результате данных трех присвоений окажется, что в переменной a будет значение b, в b - значение a.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая запрашивает у пользователя значения трех целочисленных переменных x, y, z и находит значение выражения 8x+y-5z. Очень
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Александровна1742
dmitryshigin
perfectorg
gaina6678
Александрович Алексеевна
FATAHOVAMAINA
menametov
mirdetzhuk79
Васильева-Александрович
Nikolaevich-Svetlana388
Aleksei1463
Владимирович_Ралина
AHO436
testovich1012
msangelika1010