llipskaya
?>

Одномерные массивы в Паскале. Написать программу которая должна обеспечить заполнение одномерного массива 10 Случайными числами в диапазоне от 40 до 100 Вывести его на экран затем вычислить сумму элементов значение которых превышают 60. Написать программу которая должна обеспечить заполнение одномерного массива 6 Случайными вещественными числами вывести его на экран затем вычислить произведение элементов массива

Информатика

Ответы

sergeyshuvalov

)нипонил)

Объяснение:

yurick2071488

ответ:колуыиты

Объяснение:

ИльяАндреевич-Мария

const

      MAX = 20;

    var

      s:string;

      stack:array[1..MAX] of string;

      top:integer;

      i:byte;

   

    procedure Push(ch:string);

    begin

      if top>=MAX then WriteLn('Stask full')

      else

      begin

        stack[top]:=ch;

        top:=top+1;

      end;

    end;

   

    function Pop:string;

    begin

      top:=top-1;

      if top<1 then

      begin

        WriteLn('Stack underflow');

        top:=top+1;

      end

      else Pop := stack[top];

    end;

begin

top:=1;

s:='<asdf<asdf>asdf>';//правильная строка

for i:=1 to length(s) do

begin

   if s[i]='<' then Push('<');

   if s[i]='>' then

       if Pop()<>'<' then WriteLn('Ошибка!');

end;

if top<>1 then WriteLn('Ошибка!');

top:=1;

s:='<asdf<asdfasdf>';//не правильная строка

for i:=1 to length(s) do

begin

   if s[i]='<' then Push('<');

   if s[i]='>' then

     if Pop()<>'<' then WriteLn('Ошибка!');

end;

if top<>1 then WriteLn('Ошибка!');

end.

Объяснение:

Екатерина_Кирушев

K1 = int(input())

M = int(input())

K2 = int(input())

P2 = int(input())

N2 = int(input())

if M != 1:

   for i in range(1,1000):

       if i!=0 and N2==((K2-1)//i)+1:

           P1 = (((K1-1)//i)//(M-1))+1

           N1=(((K1-1)//i)%(M-1))  

if M == 1:

   N1 = 1

   for i in range(1,1000):

       if i!=0:

           while K1 % i != 0:

               K1 = K1 + 1

           P1 = (K1//i)

if K2 < P2 * N2 or N2 > M or K2 // P2 < M:

   P1 = -1

   N1 = -1

if P2 == 1 and N2 == 1:

   P1 = -1

print(P1, N1)

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Одномерные массивы в Паскале. Написать программу которая должна обеспечить заполнение одномерного массива 10 Случайными числами в диапазоне от 40 до 100 Вывести его на экран затем вычислить сумму элементов значение которых превышают 60. Написать программу которая должна обеспечить заполнение одномерного массива 6 Случайными вещественными числами вывести его на экран затем вычислить произведение элементов массива
Ваше имя (никнейм)*
Email*
Комментарий*