var a, b, с: integer;
begin
write('Введите два числа: ');
readln(a, b);
if a < b then с := a + 1 else с := b + 1;
repeat с := с - 1
until (a mod с = 0) and (b mod с = 0);
write('NOD = ', с)
end.
//2. Алгоритм с вычитанием (цикл while)
var a, b: integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
while a <> b do
if a > b then
a := a - b
else
b := b - a;
writeln('NOD = ', a);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Вариант 2 1. У исполнителя Альфа две команды, которым присвоены номера: 1. прибавь 5; 2. умножь на b (b — неизвестное натуральное число; b ≥ 2 Известно, что программа 11211 переводит число 3 в число 88. Определите значение b. 2. Ниже приведен алгоритм алг нач цел s, t ввод s ввод t если s > 8 или t > 8 то вывод "YES" иначе вывод "NO" все кон Было проведено 9 запусков алгоритма, при которых в качестве значений переменных s и t вводились следующие пары чисел: (8, 8); (9, 6); (4, 7); (6, 6); (–9, –2); (–5, 9); (–10, 10); (6, 9); (10, 6). Сколько было запусков, при которых программа напечатала «YES»? 3. Выполните задание. На бесконечном поле имеется вертикальная стена. Длина стены неизвестна. От нижнего конца стены вправо отходит горизонтальная стена также неизвестной длины. Робот находится в клетке, расположенной слева от вертикальной стены и выше горизонтальной стены. На рисунке указан один из возможных расположения стен и Робота (Робот обозначен буквой «Р»). Напишите для Робота алгоритм, закрашивающий все клетки, расположенные слева от вертикальной стены и примыкающие к ней. Требуется закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок). Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен внутри прямоугольного поля. При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе. 4. Определите значение переменной a после выполнения алгоритма: а := 6 b := 4 b := a/2*b a := 2*а + 3*b В ответе укажите одно целое число — значение переменной a. 5. Запишите значение переменной s, полученное в результате работы следующего алгоритма. алг нач цел s, k s := 0 нц для k от 4 до 9 s := s + 12 кц вывод s кон 6. У исполнителя Делитель две команды, которым присвоены номера: 1. раздели на 2 2. вычти 3 Составьте алгоритм получения из числа 41 числа 4, содержащий не более 5 команд. В ответе запишите только номера команд. 7. Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала вычисляется длина исходной цепочки символов; если она нечётна, то дублируется средний символ цепочки символов, а если чётна, то в середину цепочки добавляется буква А. В полученной цепочке символов каждая буква заменяется буквой, следующей за ней в русском алфавите (А — на Б, Б — на В и т. д., а Я — на А). Получившаяся таким образом цепочка является результатом работы алгоритма. Дана цепочка символов ЛЮК. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм)? Русский алфавит: