dmitryshigin
?>

Составить программу, которая задает массив А[5, 6] случайным образом из чисел от -10 до 10 , выводит его на экран и находит количество положительных элементов массива

Информатика

Ответы

ВалентиновичСуриковна1104
Class ArrayEven{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
  while((eArray[eArray.length-1] = in.nextLong())!=-1){
   long nArray[] = new long[eArray.length+1];
   for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
   eArray = nArray;
  } eArrayCell:
  for(int cCell = 0; cCell<eArray.length-1; cCell++){
   if(eArray[cCell]%2==0)continue;
   else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
   if(eArray[eCell]%2==0){
    eArray[eArray.length-1]=eArray[cCell];
    eArray[cCell]=eArray[eCell];
    eArray[eCell]=eArray[eArray.length-1];
    continue eArrayCell;
   }
   break;
  }
  for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
 }
}
Максим Павел
Три символа алфавита могут быть закодированы в системе счисления по основанию 3, т.е. в троичной системе счисления.
При этом под первым номером кодируется число 0, которое записано по условию как , т.е. символ F кодируется нулем.
Вторым номером кодируется число 1 и его запись по условию N, откуда мы узнаем, что символ N кодируется цифрой 1. Тогда оставшийся символ S кодируется цифрой 2. И действительно, третьей идет комбинация символов S.
Любой член в последовательности кодов может быть получен путем перевода в троичную систему числа, на единицу меньшего номеру этого члена (поскольку отсчет кодов идет с нуля, а члены последовательности нумеруются с единицы). Проверим наше построение для контрольного значения n99=NFNSS.
98(3)=10122 -> NFNSS, что соответствует условию.
Теперь само решение.
7) 6(3)=00020 -> FFFSF
27) 26(3)=00222 -> FFSSS
90) 89(3)=10022 -> NFFSS
101) 100(3)=10201 -> NFSFN
196) 195(3)=21020 -> SNFSF

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая задает массив А[5, 6] случайным образом из чисел от -10 до 10 , выводит его на экран и находит количество положительных элементов массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ngz55
Bogataya Vladimir318
alex091177443
Mbkozlov6
osipovasalex5316
aci2003
razumeiko0790
Григорьевич915
Amulenkov
ann-perminova2008
uvarovig
Мусаев Игоревич371
Сергеевич1386
sandovo590
ganzashop