savva-vika
?>

Напишите программу, которая считывает строку-разделитель и три строки, а затем выводит указанные строки через разделитель. Python сайт stepik

Информатика

Ответы

dionissia2

separator = input()

s1 = input()

s2 = input()

s3 = input()

print(s1, s2, s3, sep=separator)

alex091177443

В секунду через этот канал связи может быть передано до 86 кБайт = 86*1024*8 бит = 704512 бит

В эту же секунду в записи передаётся 44100 двоичных значений для каждого из двух каналов (т.к. стерео). То есть, всего 2*44100 = 88200 значений

Поделим число бит, передаваемое на максимальной скорости на число двоичный значений, и мы получим сколько бит можно выделить максимально на каждое двоичное значение:

704512 / 88200 ≈ 7,988 бит

То есть, для передачи 8 бит на значение совсем чуть чуть не хватает скорости.

Получается, разрядность дискретизации могла быть максимум 7 бит.

Примечание: для передачи 8 бит на значение нужна скорость 8*88200/8/1024 = 86,1328125 кБ/с

Shurshilina850

Если что это джава.

1)  Scanner num = new Scanner(System.in);

 int first;

 System.out.print("Введите число: ");

 first = num.nextInt();

 if(first > 0) {

 first = first * 3;

 System.out.println(first);

 }

 else if(first < 0) {

  first = first / 4 ;

  System.out.println(first);

 }

Это первое

2)

 Scanner num = new Scanner(System.in);

 int first, second;

 System.out.print("Введите первое число: ");

 first = num.nextInt();

 System.out.print("Введите второе число: ");

 second = num.nextInt();

 if(first > second) {

  System.out.println(first);

 }

 else if(first==second) {

   

 }

 else {

  System.out.println(second);

 }

Это второе

А да и не забудь импортировать java.util.Scanner;

без этого работать не будет

Удачи)

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая считывает строку-разделитель и три строки, а затем выводит указанные строки через разделитель. Python сайт stepik
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

saryba
ok-49566
Aleksandr556
mail66
miss1380
timonina29
Иванович-Васильевна1153
Напишите практическую​ по географии
verakmves
oniks-plus
Yulechkaakulova1993
Igorevich_Aleksandrovna1599
sryzhova6392
Galina-3639220565
Smolkovaya
osipov1984osipov