Khlistova1488
?>

Составьте программу, которая вводит с клавиатуры два целых числа, а затем выводит их частное и разность, для нахождения разности и частного не использовать дополнительные переменные. Пример работы программы: Введите два целых числа a и b 12 3 Разность: 9 Частное: 4

Информатика

Ответы

Vitalevich1799

var

   i: Integer;

   l: Single;

   counter: Integer;

begin

 counter := 0;

 for i := 0 to 14 do begin

   Read(l);

   if l >= 165 then

       counter := counter + 1 ;

 end;

 Writeln(counter);

end.

Второй вариант

const

 cN: Integer = 15;

 cMinSuitableLength: Single = 165;

var

 arr: array [0..14] of Single;

 i, counter: Integer;

begin

 for i := 0 to Length(arr) - 1 do

   Read(arr[i]);

 counter := 0;

 for i := 0 to Length(arr) - 1 do

   if arr[i] >= cMinSuitableLength then

     counter := counter + 1;

 Writeln(counter);

end.

Объяснение:

vshumilov

var

   i: Integer;

   l: Single;

   counter: Integer;

begin

 counter := 0;

 for i := 0 to 14 do begin

   Read(l);

   if l >= 165 then

       counter := counter + 1 ;

 end;

 Writeln(counter);

end.

Второй вариант

const

 cN: Integer = 15;

 cMinSuitableLength: Single = 165;

var

 arr: array [0..14] of Single;

 i, counter: Integer;

begin

 for i := 0 to Length(arr) - 1 do

   Read(arr[i]);

 counter := 0;

 for i := 0 to Length(arr) - 1 do

   if arr[i] >= cMinSuitableLength then

     counter := counter + 1;

 Writeln(counter);

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая вводит с клавиатуры два целых числа, а затем выводит их частное и разность, для нахождения разности и частного не использовать дополнительные переменные. Пример работы программы: Введите два целых числа a и b 12 3 Разность: 9 Частное: 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gurman171
infoproletarskay745
gbelihina
flerbuket332
aluka
luxoutlet
zhmulyov-denis8
karinasy4ewa
Nonstop788848
germanleon
abrolchik8511
espectr-m
Aivazyan
I.B.Petrishchev
maksim1lssah575