vikka30
?>

Напишите программу, которая в последовательности целых чисел определяет количество отрицательных чисел и сумму положительных. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: количество отрицательных чисел и сумму положительных.

Информатика

Ответы

Mariya Filippov

# Python 3.x

# sequence - данная нам последовательность чисел

odds=int()

sumary=int()

for digit in sequence:

   if digit == 0: break

   if digit % 2 == 0: sumary=sumary + digit

   else: odds=odds + 1

print("Sumary: ", sumary)

print("Odds amount: ", odds)

purbuevat56524

Человек может рассказать не только о признаках объекта, но и об отношениях, в которых этот объект находится с другими объектами. Например:  

• «Иван — сын Андрея»;  

• «Эверест выше Эльбруса»;  

• «Винни Пух дружит с Пятачком»;  

• «21 кратно 3»;  

• «Кострома такой же старинный город, как и Москва»;  

• «текстовый процессор входит в состав программного обеспечения компьютера»;  

• «один байт равен восьми битам».

В каждом из приведённых предложений выделено имя отношения, которое обозначает характер связи между двумя объектами.

Отношение — это взаимная связь, в которой находятся какие-либо объекты.

Одним и тем же отношением могут быть попарно связаны несколько объектов. Соответствующее словесное описание может оказаться очень длинным, и тогда в нём трудно разобраться.

Пусть про населённые пункты А, Б, В, Г, Д и Е известно, что некоторые из них соединены железной дорогой: населённый пункт А соединён железной дорогой с населёнными пунктами В, Г и Е, населённый пункт Е — с населёнными пунктами А, В, Г и Д.

Для большей наглядности имеющиеся связи («соединён железной дорогой») можно изобразить линиями на схеме отношений. Объекты на схеме отношений могут быть изображены кругами, овалами, точками, прямоугольниками

anitanemtsewa

Чат, чаттер (англ. chatter «болтать») — средство обмена сообщениями по компьютерной сети в режиме реального времени, а также программное обеспечение, позволяющее организовывать такое общение.

Применение:

1-Чаты, использующие технологию Push. Вместо периодической отправки запросов серверу о новых сообщениях, используются входящие сообщения от сервера, что позволяет отправлять и получать сообщения, расходуя меньше трафика

2- Программы-чаты для общения в локальных сетях

Видеоконференция (от англ. videoconference) — область информационной технологии, обеспечивающая одновременно двустороннюю передачу, обработку, преобразование и представление интерактивной информации на расстоянии в режиме реального времени с аппаратно-программных средств вычислительной техники.

Применение:

1- Видеоконференции в дистанционном обучении

2- Судопроизводство

IP-телефони́я (произносится «айпи́-телефони́я») — телефонная связь по протоколу IP. Под IP-телефонией подразумевается набор коммуникационных протоколов, технологий и методов, обеспечивающих традиционные для телефонии набор номера, дозвон и двустороннее голосовое общение, а также видеообщение по сети Интернет или любым другим IP-сетям.

Применение:

1- IP-сети с применением софтсвитча, IP-АТС или виртуальной АТС.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая в последовательности целых чисел определяет количество отрицательных чисел и сумму положительных. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: количество отрицательных чисел и сумму положительных.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ольга1801
porotikova1004
silviya
gaina6678
Natalimis416024
dmitriy
lokos201272
chetverikovalex3738
mariavayda88734
kabinet17
lukur2005
matterfixed343
stertumasova29
maksmi
Шитенков