5 цифр ответ 10010
Объяснение:
При переводе в двоичную систему мы каждое число делим на 2. 18 мы делим на 2 берём по 9. От 18-18=0. Дальше где в ответе у нас получилось 9 мы эту девятку делим на 2 берём по 4 это 8 от 9-8=1 пишим 1. Дальше мы 4 делим на 2 берём по 2 ответ 4 будет ноль. Потом 2 делим на 2 берём по 1. 2-2=0
И вот те чифры которые у нас остались от деления когда мы вычитал от 18-18,от 9-8. Мы их записываем в обратном порядке. Вот и ответ 10010. Надеюсь хорошо объяснила
Если не понятно спрашивай ;)
Поделитесь своими знаниями, ответьте на вопрос:
Практическая работа №3. Тема: "Строковые и логические величины в языке Pascal»". Цель: научиться работать со строковыми и логическими величинами в программе. Ход работы: Задание 1. Составить программу, определяющую длину введенного вами слова. 1. Откройте среду программирования Pascal. 2. Введите программу: program dlina; uses crt; var s: string; t:integer; begin clrscr; writeln (‘Введите произвольное слово’); readln (s); t:=length(s); writeln (‘длина слова равна’, t); readkey; end. 3. Проверьте программу на наличие ошибок и запустите на выполнение. Задание 2. Составить программу, определяющую истинность высказывания "Число n является четным" program chetn; uses crt; var n: integer; a: boolean; begin clrscr; write ('Введите исходное число'); readln (n); a:=n mod 2=0; writeln ('Число ', n, ' является четным - ', a); readkey; end. Самостоятельная работа 1. Склеить 2 произвольно введенных слова.
Авторлық құқық
1) автор - шығармашылық еңбегімен ғылым, әдебиет, өнер туындысын жасаған жеке тұлға;
2) авторлық құқық - автордың жеке мүліктік емес және мүліктік құқықтары;
3) авторлық құқықты және сабақтас құқықтарды қорғаудың техникалық құралы - туындыларға немесе сабақтас құқықтар объектілеріне қол жеткізуді бақылайтын, автор, сабақтас құқықтар иесі немесе өзге де айрықша құқықтар иесі туындыларға немесе сабақтас құқықтар объектілеріне қатысты рұқсат етпеген іс-әрекеттерді жүзеге асыруды болғызбайтын не шектейтін техникалық (бағдарламалық-техникалық) құрылғы немесе оның компоненттері;
Объяснение: