a: array [1..20] of 2..5; //Массив оценок учеников
i: integer;
n: array [2..5] of 2..5; //Массив счетчиков оценок
begin
for i:= 2 to 5 do //Обнуляем счетчики оценок
n[i]:= 0;
for i:= 1 to 20 do //Вводим оценки учеников и считаем их
begin
writeln('Введите оценку ', i, ' ученика');
readln(a[i]);
if a[i] = 2 then n[2]:= n[2] + 1;
if a[i] = 3 then n[3]:= n[3] + 1;
if a[i] = 4 then n[4]:= n[4] + 1;
if a[i] = 5 then n[5]:= n[5] + 1;
end;
for i:= 2 to 5 do
writeln('Количество получивших ', i, ' за диктант равно: ', n[i]); {Выводим значения счетчиков}
end.
3) Program zada4a3;Поделитесь своими знаниями, ответьте на вопрос:
РЕШИТЬ В ПИТОНЕ Программа вычисляет последнюю цифру d заданного числа n. На входе: целое число n. На выходе: целое однозначное число d (0≤d<10 Входные данные: 1234 Выходные данные: 4
-Да может,если массив имеет вещественный тип
Для чего необходимо описание массива?
-Чтобы создать массив с указанным количеством элементов и типом их значений
Что вы можете сказать о массиве, сформированном следующим образом:
а)Тут мы заполняем массив a с индексами от 1 до 10 случайными целыми числами от -50 до 50
б)Тут мы заполняем массив a с индексами от 1 до 20, присваивая каждому элементу массива значение его индекса
в)Тут мы заполняем массив a с индексами от 1 до 5, присваивая каждому элементу массива удвоенное значение его индекса минус 1