Moroshkina-Aristova2011
?>

Входные данные Первая строка содержит число N ( N ≥ 1 В следующих N строках записаны целые числа, по одному в каждой строке. Выходные данные Программа должна вывести в одной строке сумму и произведение введённых чисел, разделив их пробелом.

Информатика

Ответы

avdeevo

Плюсы:

-Возможность доступа к данным с любого компьютера, имеющего выход в Интернет.

-Высокая вероятность сохранения данных даже в случае аппаратных сбоев.

Минусы:

-Провайдер имеет возможность просматривать данные клиента (если они не защищены паролем), которые также могут попасть в руки хакеров, сумевших взломать системы защиты провайдера.

-Общая производительность при работе с данными в «облаке» может быть ниже, чем при работе с локальными копиями данных.

Привел по два плюса и минуса, на всякий случай.  

lawyer-2019

var x,y : Array of integer;

j,i,o,e,n1,n2 :integer;

begin

 writeln('Первый массив');

 writeln('Сколько нулей?');

 readln(o);

 writeln('Сколько единиц?');

 readln(e);

 writeln('С какого числа начинаются единицы по размеру массива?');

 readln(n1);

 writeln('С какого числа начинаются нули по размеру массива?');

 readln(n2);

 if (n1 > n2) and (e > o) then

   begin

   setlength(x,(n1+e));

   end

 else

   begin

   setlength(x,(n2+o))

   end;

 for i:= 0 to 10 do

    begin

    Write('-':2);

 end;

 writeln();

 writeln('Заполнение первого массива');

 for i:= 0 to 10 do

    begin

      Write('-':2);

    end;

 Writeln();

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

         if e = 0 then

          begin

          end

        else

          begin

            x[i] :=0;

          end;

         for j := n1 to (n1+e) do

           begin

           x[j] := 1;

           end;

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

         if o = 0 then

          begin

          end

        else

          begin

            x[i] :=0;

          end;

        for j := n1 to (n1+e) do

         begin

         x[j] := 1;

         end;

       end;

   end;

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

         Write(x[i],' ');

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

        Write(x[i],' ');

       end;

   end;

 writeln();

 writeln('Второй массив');

 writeln('Сколько нулей?');

 readln(o);

 writeln('Сколько единиц?');

 readln(e);

 writeln('С какого числа начинаются единицы по размеру массива?');

 readln(n1);

 writeln('С какого числа начинаются нули по размеру массива?');

 readln(n2);

 if (n1 > n2) and (e > o) then

   begin

   setlength(y,(n1+e));

   end

 else

   begin

   setlength(y,(n2+o))

   end;

 for i:= 0 to 10 do

    begin

    Write('-':2);

 end;

 writeln();

 writeln('Заполнение второго массива');

 for i:= 0 to 10 do

    begin

      Write('-':2);

    end;

 Writeln();

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

        if e = 0 then

          begin

          end

        else

          begin

          y[i] :=0;

          end;

         for j := n1 to (n1+e) do

           begin

           y[j] := 1;

           end;

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

        if o = 0 then

          begin

          end

        else

          begin

          y[i] :=0;

          end;

        for j := n1 to (n1+e) do

         begin

         y[j] := 1;

         end;

       end;

   end;

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

         Write(y[i],' ');

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

        Write(y[i],' ');

       end;

   end;

 

 

end.


Какие ситуации смог представил то и смог сделать. Тестером побудешь ты.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Входные данные Первая строка содержит число N ( N ≥ 1 В следующих N строках записаны целые числа, по одному в каждой строке. Выходные данные Программа должна вывести в одной строке сумму и произведение введённых чисел, разделив их пробелом.
Ваше имя (никнейм)*
Email*
Комментарий*