Vladimirovich1898
?>

Напишите программу определения суммы членов ряда с точностью e=10^3, общий член которого an задан формулой: an = xn (2n-1) / n! 2-вр. an = x/n2;

Информатика

Ответы

ev27076878
1)var ar:array[1..4] of integer;
begin
ar[1]:=2;ar[2]:=2;ar[3]:=2;ar[4]:=2;
end.
2)var ar:array[1..5] of integer;
a:integer;
begin
for a:=1 to 5 do
begin;
ar[a]:=a;
writeln(ar[a]);
end;
end.
3)var ar:array[1..7] of integer;
a,b,c:integer;
begin
readln(a);
for b:=1 to 7 do
begin;
ar[b]:=a+b-1;
writeln(ar[b]);
end;
end.
4)var ar:array[1..6] of integer;
b:integer;
begin
for b:=1 to 6 do
begin;
readln(ar[b]);
ar[b]:=ar[b]*2;
writeln(ar[b]);
end;
end.
5)var ar:array[1..6] of integer;
b:integer;
begin
randomize;
for b:=1 to 6 do
begin;
ar[b]:=random(10);
ar[b]:=ar[b]*ar[b];
writeln(ar[b]);
end;
end.
smook0695

#include "stdafx.h"

#include <iostream>

#include <windows.h>

using namespace std;

int main()  

{

setlocale(LC_ALL, "Russian");

int n = 0, m = 0;

cout << "Введите размерность двумерного массива вида mass[n][m] :" << endl;

cout << "n = ";

cin >> n;

cout << "m = ";

cin >> m;

int **mass = new int* [n];

for (int i = 0; i < n; i++)

{

 mass[i] = new int[m];

}

cout << "Заполните массив по столбцам:" << endl;

for (int j = 0; j < m; j++)  

{

 cout << "Столбец [" << j + 1 << "]: " << endl;

 for (int i = 0; i < n; i++)  

 {

  cin >> mass[i][j];

 }

}

int buffer = 0;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  if (i == j)

  {

   if (mass[i][j] > buffer)

   {

    buffer = mass[i][j];

   }

  }

 }

}

cout << "\nНаибольший элемент по главной диагонали: " << buffer << endl;

for (int i = 0; i < n; i++)

{

 delete[] mass[i];

}

delete[] mass;

return 0;

}

Объяснение:

Написал в visual studio, все работает, по итогу программа выводит наибольший элемент по главной диагонали. Ввод матрицы производится по столбцам, не забудь про это.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу определения суммы членов ряда с точностью e=10^3, общий член которого an задан формулой: an = xn (2n-1) / n! 2-вр. an = x/n2;
Ваше имя (никнейм)*
Email*
Комментарий*