lovel24
?>

класс информатика 1. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 4 команд, которая преобразует число 6 в число 29. ответ: 2. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 5 команд, которая преобразует число 2 в число 26. ответ: 3. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 5 команд, которая преобразует число 6 в число 51. ответ: 4. У исполнителя Калькулятор две команды: 1. прибавь 2 2. умножь на 3 Напишите программу из 5 команд, которая преобразует число 5 в число 83. ответ: 5. У исполнителя Калькулятор две команды: 1. вычти 2 2. умножь на 3 Напишите программу из 5 команд, которая преобразует число 8 в число 50. ответ: 6. У исполнителя Калькулятор две команды: 1. вычти 3 2. умножь на 2 Напишите программу из 4 команд, которая преобразует число 8 в число 40. ответ: 7. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 4 команд, которая преобразует число 4 в число 36. ответ:

Информатика

Ответы

GALINAMTO
//Pascal ABC.NET v3.0 сборка 1111

Const
 n=5;

Var
 ma:array[1..n,1..n] of integer;
 i,j:integer;
begin
 writeln('Matrix reading...');
 for i:=1 to n do
  begin
   writeln;
    for j:=1 to n do
      readln(ma[i,j]);
  end;
 writeln('First matrix:');
 for i:=1 to n do
  begin
   writeln;
    for j:=1 to n do
     begin
      write(ma[i,j]:4);
      if (ma[i,j]<-8) or (ma[i,j]>6) then ma[i,j]:=sqr(ma[i,j]);
     end;
  end;
 writeln;
 writeln('Final matrix:');
 for i:=1 to n do
  begin
   writeln;
    for j:=1 to n do
     write(ma[i,j]:4);
  end;
end.

Пример ввода:
1
2
3
4
5

6
7
8
9
1

2
3
4
5
6

7
8
9
1
2

3
4
5
6
7
Пример вывода:
First matrix:
   1   2   3   4   5
   6   7   8   9   1
   2   3   4   5   6
   7   8   9   1   2
   3   4   5   6   7
Final matrix:
   1   2   3   4   5
   6  49  64  81   1
   2   3   4   5   6
  49  64  81   1   2
   3   4   5   6  49
ea-office
//Pascal ABC.NET v3.0 сборка 1111

Const
 s=5;

Var
 ar:array[1..s] of integer;
 n,m,i:integer;
begin
 writeln('N');
 readln(n);
 writeln('M');
 readln(m);
 writeln('Array:');
 for i:=1 to s do
   readln(ar[i]);
 writeln('First array:');
 for i:=1 to s do
  begin
   write(ar[i]:4);
   if ar[i] div n<>0 then ar[i]:=ar[i]+m;
  end;
 writeln;
 writeln('Final array:');
  for i:=1 to s do
   write(ar[i]:4);
end. 

Пример ввода:
3
3
1
2
3
4
5
Пример вывода:
First array:
   1   2   3   4   5
Final array:
   1   2   6   7   8

//Блок-схема во вложении
Ввести двумерный массив a. все элементы, которые при целочисленном делении на n ненулевое значение,

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

класс информатика 1. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 4 команд, которая преобразует число 6 в число 29. ответ: 2. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 5 команд, которая преобразует число 2 в число 26. ответ: 3. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 5 команд, которая преобразует число 6 в число 51. ответ: 4. У исполнителя Калькулятор две команды: 1. прибавь 2 2. умножь на 3 Напишите программу из 5 команд, которая преобразует число 5 в число 83. ответ: 5. У исполнителя Калькулятор две команды: 1. вычти 2 2. умножь на 3 Напишите программу из 5 команд, которая преобразует число 8 в число 50. ответ: 6. У исполнителя Калькулятор две команды: 1. вычти 3 2. умножь на 2 Напишите программу из 4 команд, которая преобразует число 8 в число 40. ответ: 7. У исполнителя Удвоитель две команды: 1. прибавь 1 2. умножь на 2 Напишите программу из 4 команд, которая преобразует число 4 в число 36. ответ:
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AlekseiMardanova
Сергеевна-С.А.1549
Amelin-Alipova
Popov Valentina1324
manager-3
Yekaterina
Karlova1507
Matveevanastya0170
bestform
petrakovao
msburmis
zakup-r51
Cannabikh
Morozova-Starikov
Никита_Тузов
▲