Dmitriy793
?>

Составьте программу, которая печатает в первой строке знак &, во второй – повтор через два пробела '& &', в третьей - '& & &', ..., в строке с номером 9 - 9 pаз & через пробел. Печать строки оформить через процедуру. Число строк вводить с клавиатуры. Текст Вашей программы сохранить в файл PascalABC.net. Прикрепить файл программы к этому заданию. После begin основной программы написать что делает эта программа writeln('Программа печает(выводит на экран.заполнить) ');

Информатика

Ответы

severbykova
Const n=20;
type omas=array[1..n] of integer;
Procedure Del (var z:omas; k:byte); 
var i:byte; 
begin 
for i:=k to n-1 do z[i]:=z[i+1]; 
z[n]:=0; 
end; 
var a:omas; i,b:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(20);
 write(a[i]:4);
 end;
writeln;
b:=6;
i:=1;
while (i<=n)and(a[i]<>b) do i:=i+1;
if i<=n then
  begin
  Del(a,i);
 writeln('Размерность массива = ',n-1);
 for i:=1 to n-1 do write(a[i]:4);
 writeln;
 end  else writeln('Массив не изменился');
end.
Пример:
  12  13   6   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
Размерность массива = 19
  12  13   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
moskwa999
1) F=Av(¬A&B)
По закону дистрибутивности раскроем скобки
(Av¬A)&(AvB)
Av¬A = 1, значит остаётся AvB

2) F =A&(¬AvB)
По тому же закону раскрываем скобки
(A&¬A)v(A&B)
A&¬A = 0, значит остаётся A&B

3. (AvB)&(¬BvA)&(¬CvB)
По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид
A&(¬CvB)
Можно раскрыть скобки, получим
A&¬C v A&B

4) F =(1v(AvB))v((AC)&1) 
Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1
Получаем выражение
1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1
ответ 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая печатает в первой строке знак &, во второй – повтор через два пробела '& &', в третьей - '& & &', ..., в строке с номером 9 - 9 pаз & через пробел. Печать строки оформить через процедуру. Число строк вводить с клавиатуры. Текст Вашей программы сохранить в файл PascalABC.net. Прикрепить файл программы к этому заданию. После begin основной программы написать что делает эта программа writeln('Программа печает(выводит на экран.заполнить) ');
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pavlova7771960
Azarenkoff
aeykin
Nastyakarysheva8750
ustinov434
annaar497
Alekseevna1064
Blekjek730
maroseyka
Окунева-Мотова
Суретті түзету дегеніміз не?​
Наталья_Васищев
stertumasova29
AkulovaAnastasiya
juliaipatova1739
choia