fursov-da
?>

2) Составить программу, в которой элементы массива A[3, 4] вводятся вручную, затем массив выводится на экран и находится количество четных элементовмассива.​

Информатика

Ответы

Yurok9872

Program pr1;

Var A:array [1..10] of integer;

i,k:integer;

begin

for i:=1 to 10 do  

read (A[i]);

k:=0;

for i:=1 to 10 do  

if A[i] mod 2=0 then  

k:=k+1;

writeln;

writeln (k);

end.

Объяснение:

проверь в паскаль

pryvalovo48

Program ToDec;

Uses crt;
var s:string;
n,l,i:integer;

 

function Pow(x,y:integer):integer;
begin
     if y>0 then Pow:=Pow(x,y-1)*x
               else Pow:=1;
end;

function ToDec(A : string) : integer;
var L : Byte;
begin
      if A = '' then ToDec := 0
                else begin
                              L := length(A);
                               case A[1] of
                                     '0' : ToDec := ToDec(Copy(A, 2, L - 1));
                                     '1' : ToDec := Pow(2, L - 1) + ToDec(Copy(A, 2, L - 1));
                                end;
     end;
end;

begin
     clrscr;
     write('Введите двоичное число: ');
     readln(s);
      writeln('Это число в десятичной системе : ', ToDec(S));
 readkey;
end.

 

 

 

elenaperemena8
Program Vby_1;
uses crt;
var a,b,c:real;
begin
  writeln('***   Alphaues is thinking...   ***');
  writeln('Ok, введите катеты: ');
  write('a= ');readln(a);
  write('b= ');readln(b);
  writeln('Периметр прямоугольного треугольника = ',a+b+sqrt(a*a+b*b):8:2);
end.

Program Vby_2;
uses crt;
var a,b,h,t:real;
begin
  writeln('***   Alphaues is thinking...   ***');
  writeln('Ok, введите данные: ');
  write('Одно основание = ');readln(a);
  write('Другое основание = ');readln(b);
  write('Высота = ');readln(h);
  t:=abs(a-b)/2;
writeln('Периметр трапеции =',a+b+sqrt(h*h+t*t):8:2);
end.

Program Vby_3;
uses crt;
var s:integer;
begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите расстояние в сантиметрах: '); readln(s);
  write('Число полных метров = ',s div 100);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

2) Составить программу, в которой элементы массива A[3, 4] вводятся вручную, затем массив выводится на экран и находится количество четных элементовмассива.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alaevluka77
maroseyka
elmira01048775
Иванникова736
Александрович686
annashersheva
ksankaaleks611
EVLAMPIN56
Новицкий1107
Sergeevich-irina
Lopatkin_Shchepak174
makscska22879
ann-perminova2008
Евгения-Валерий
Ольга1520