zvanton
?>

Составьте программу, которая определяет, какое из трех чисел наибольшее. Числа вводятся с клавиатуры

Информатика

Ответы

reznikvi
Средства информационных и коммуникационных технологий в системе образования

Все средства ИКТ, применяемые в системе образования можно разделить на два типа: аппаратные и программные. (Сводную таблицу средств ИКТ см. в Приложении 1).

Аппаратные средства:

Компьютер - универсальное устройство обработки информации.

Принтер позволяет фиксировать на бумаге информацию, найденную и

созданную учащимися или учителем для учащихся. Для многих школьных применений желателен цветной принтер.

Проектор повышает уровень наглядности в работе учителя, а также возможность представлять учащимся результаты своей работы всему классу.

Телекоммуникационный блок дает доступ к российским и мировым информационным ресурсам, позволяет вести дистантное обучение и переписку с другими школами.

Устройства для ввода текстовой информации и манипулирования экранными объектами - клавиатура и мышь Особую роль соответствующие устройства играют для учащихся с проблемами двигательного характера, например, с ДЦП.

Устройства для записи (ввода) визуальной и звуковой информации (сканер, фотоаппарат, видеокамера, аудио- и видеомагнитофон) дают возможность непосредственно включать в учебный процесс информационные образы окружающего мира.

Устройства регистрации данных (датчики с интерфейсами) существенно расширяют класс физических, химических, биологических, экологических процессов, включаемых в образование при сокращении учебного времени, затрачиваемого на рутинную обработку данных.

Управляемые компьютером устройства дают возможность учащимся различных уровней освоить принципы и технологии автоматического управления.

Внутриклассная и внутришкольная сети позволяют более эффективно использовать имеющиеся информационные, технические и временные (человеческие) ресурсы, обеспечивают общий доступ к глобальной информационной сети

Аудио-видео средства обеспечивают эффективную коммуникативную среду для воспитательной работы и массовых мероприятий.

Программные средства:

Общего назначения и связанные с аппаратными (драйверы и т. п. ) дают возможность работы со всеми видами информации.

Источники информации - организованные информационные массивы энциклопедии на компакт-дисках, информационные сайты и поисковые системы Интернета, в том числе специализированные для образовательных применений.

Виртуальные конструкторы позволяют создавать наглядные и символические модели математической и физической реальности и проводить эксперименты с этими моделями.

Тренажеры позволяют отрабатывать автоматические навыки работы с информационными объектами: ввод текста, оперирование с графическими объектами на экране и пр.

Тестовые среды позволяют конструировать и применять автоматизированные испытания, в которых учащийся полностью или частично получает задание через компьютер, и результат выполнения задания также полностью или частично оценивается компьютером.

Комплексные обучающие пакеты (электронные учебники) - сочетания программных средств перечисленных выше видов - в наибольшей степени автоматизирующие учебный процесс в его традиционных формах, наиболее трудоемкие в создании, наиболее ограничивающие самостоятельность учителя и учащегося.

Информационные системы управления обеспечивают прохождение информационных потоков между всеми участниками образовательного процесса: учащимися, учителями, администрацией, родителями, общественностью.

Экспертные системы - программная система, использующая знания специалиста-эксперта для эффективного решения задач в какой-либо предметной области.

(См. также Приложение 2 – ИКТ применяемые в высшей школе России) .

1.2.2. Информационные и коммуникационные технологии в научной деятельности

Прорыв в области ИКТ, происходящий в настоящее время, заставляет пересматривать вопросы организации информационного обеспечения научно-исследовательской деятельности. Можно выделить несколько возможностей использования информационных технологий:

1. для поиска литературы
Vs1377
//PascalABC.NET
var
    b : array of integer;
    m : integer;
begin
// Ввод данных
    var n := ReadInteger('Введите число N всех чисел массива: ');
    var k := ReadInteger('Введите число К "красивых" чисел: ');
    writeln('Введите все числа в массиве');
    var a := ReadArrInteger(n);
// Резервируем место для слагаемых
    b := new integer[k];
// Просмотрим все данные числа
    foreach var i in a do
// Выберем только кратные трем
        if i mod 3 = 0 then begin
// Если есть свободное место, поместим туда
            m := b.FindIndex(x -> x=0);
            if m <> -1 then b[m] := i
            else
// Если свободного места нет, найдем наибольший элемент
// и заменим его
                begin
                m := b.FindIndex(x -> (x>i) and (x=b.Max));
                if m <> -1 then b[m] := i;
            end;
        end;
// Выведем сумму
    write('Сумма элементов - ', b.Sum)
end.

Дано n целых чисел. число называется красивым, если его можно разделить на 3 без остатка. вам нужн
Дано n целых чисел. число называется красивым, если его можно разделить на 3 без остатка. вам нужн

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая определяет, какое из трех чисел наибольшее. Числа вводятся с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ksvish2012
vsemvsego306
Iselickaya1890
ИванМолчанов
dailyan539
Лилия-Карпухина337
Кулагина_Владимир1179
ЕленаГерасимова
olgalooo
cometa94558
sov0606332
zakaz6354
Сергей_Крутикова114
samoilovcoc
bulin2001