serge-lysoff
?>

Ввести с клавиатуры натуральное число N. Найти произведение: Р = (1 + х)·(3+2х)·(5+3х)·... . (N множителей 1. Составить блок-схему. 2. Написать программу на С++.

Информатика

Ответы

tpomyleva6

var

 n: integer;

 x:real;

 p:double;

begin

 Writeln('Введите n и x');

 Read(n);Readln(x);p:=1;

 while (n > 0) do

   begin

     p:= p * (1 + 2*(n-1) + n*x);

     n:= n - 1;

   end;

 Writeln(p);

end.

Пример:

Введите n и x

3 2

231

Объяснение:

kbndbyb6

#include <iostream>

using namespace std;

int main()

{

  int x,N,P,k1,k2;

  k1=1;

  k2=1;

  P=1;

  cin>>N>>x;

  while (k1<=N)

  {

      P*=(k1+k2*x);

      k1+=2;

      k2++;

  }

 

  cout<<P;

   return 0;

}

Объяснение:


Ввести с клавиатуры натуральное число N. Найти произведение: Р = (1 + х)·(3+2х)·(5+3х)·... . (N множ
Ввести с клавиатуры натуральное число N. Найти произведение: Р = (1 + х)·(3+2х)·(5+3х)·... . (N множ
mrropevvv
Var
  x,y:real;
begin
  Write('Введите координаты x и y точки: '); Readln(x,y);
  Write('Точка с указанными координатами ');
  if not ((y<=x) and (x<=2) and ((sqr(x)+sqr(y))>=4) and (y>=0)) then
    Write('не ');
  Writeln('принадлежит заштрихованной области.')
end.

Примеры выполнения программы:
Введите координаты x и y точки: 1.9 2.1
Точка с указанными координатами не принадлежит заштрихованной области.

Введите координаты x и y точки: 1.9 1.82
Точка с указанными координатами принадлежит заштрихованной области.

Введите координаты x и y точки: 1 -3
Точка с указанными координатами не принадлежит заштрихованной области.
spz03
На каком языке програмирования?
на Java
public class MyClass {
public static void main(String[] args) throws Exception{
BufferedReader reader = new BufferedReader(new InputStreamReader(System.in)));
System.out.println("введите координаты");
System.out.println("x:");
Integer x = Integer.valueOf(reader.println());
System.out.println("y:");
Integer y = Integer.valueOf(reader.println());
Заштрихованая область как определяется?
пусть она уже задана и имеет вид прямоугольника.
int lefiXofSpace = 5;
int rightXofSpace = 10;
int upYof Space = 7;
int downYof Space = 5;
if((x >= leftXofSpace && x <= rightXofSpace) && (y >= downYofSpace && y <= upYofSpace)) {
System.out.printl("Точка попала в заштрихованую область");
} else {
System.out.printl("Точка не попала в заштрихованую область");
}
}
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ввести с клавиатуры натуральное число N. Найти произведение: Р = (1 + х)·(3+2х)·(5+3х)·... . (N множителей 1. Составить блок-схему. 2. Написать программу на С++.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Екатерина
Татьяна_Вологжин
Выбери верный адрес ячейки. 39 PP E 54
lezzzzka5510
podenkovaev314
airon-082054
Sidunevgeniya
teashop
seletan1
om805633748
afilippov3321
sport2293032
gaydukov5706
superbalsa
Морозов
Yurevich1243