bochkarevazh
?>

Написать программу, которая вводит два целых числа a и b (a ≤ b) и выводит сумму квадратов всех чисел от a до b.

Информатика

Ответы

Gennadievna bessonov
//Pascal
//1
begin
writeln((15 div 4)*18);
end.

//2
var a, b, c: real;
begin
write('Введите стороны треугольника A B C: '); readln(a, b, c);
writeln('Периметр = ', a + b + c);
end.

//3
var a, b: real;
begin
write('Введите стороны прямоугольника A B: '); readln(a, b);
writeln('Площадь = ', a * b);
writeln('Периметр = ', 2 * (a + b));
end.

//4
var a, b, c: real;
begin
write('Введите ребра A, B, C: '); readln(a, b, c);
writeln('Площадь = ', (2*(a*b+b*c+a*c)):0:1);
writeln('Объем = ', (a*b*c):0:1);
end.

//5
var r: real;
begin
write('Введите радиус: '); readln(r);
writeln('Длина окружности = ', (2 * pi * r):0:1);
end.
Вагифович
--1--
а) 453₁₀ = 111000101₂ = 705₈ = 1С5₁₆
б) 481₁₀ = 111100001₂ = 741₈ = 1E1₁₆
в) 461.25₁₀ = 111001101.01₂ = 715.2₈ = 1CD.4₁₆
г) 667.25₁₀ = 1010011011.01₂ = 1233.2₈ = 29B.4₁₆
д) 305.88₁₀ = 100110001.1110₂ = 461.7024₈ = 131.E147₁₆
--2--
а) 111001010₂ = 458₁₀
б) 1101110001₂ = 881₁₀
в) 1001010100.10001₂ = 596.53125₁₀
г) 111111110.11001₂ = 510.78125₁₀
д) 1634.35₈ = 924.453125₈
е) 6B.A₁₆ = 107.625₁₀
--3--
а) 101110001₂ + 101111001₂ = 1011101010₂
б) 1110001110₂ + 1100110111₂ = 11011000101₂
в) 10000011010.01₂ + 1010010110.01₂ = 11010110000.1₂
г) 1710.2₈ + 773.24₈ = 2703.44₈
д) 3E7.7₁₆ + 32.2₁₆ = 419.9₁₆
--4--
а) Прямой код: 0.1111000010₂ – 0.1110000011₂ = 0.0000111111₂
    Обратный: 0.0000111101₂ – 0.0001111100₂ = 000000000000000.0000111111₂
    Дополнительный: 0.0000111101₂ – 0.0001111100₂ = 000000000000000.0000111111₂

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вводит два целых числа a и b (a ≤ b) и выводит сумму квадратов всех чисел от a до b.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alexandergulyamov
margarita25061961
Бражинскене_Алексей
Pilotmi247074
serge-lysoff
Irina_Nikolai
Галина-Юлия1292
СмыковаДарья1969
Pervosha
Lugovoi
predatorfishing608
Maloletkina-marina2
sryzhova6392
sveta740450
pravovoimeridian