guzelda19904850
?>

Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка от 5 до 22. Оформите вывод элементов на экран в строчку.Пояснение.Обратите внимание, что случайные числа задаются функцией random(x Для того чтобы задать случайные числа из промежутка от a до b есть формула x:=random(b-a+1)+a, в нашем случаеx:=random(18)+5текст программыvar m: array [1..10] of integer; i: integer;beginfor i:=1 to 10 dobeginm[i]:= Random(18)+5;write(m[i], ' ');end;end. ​

Информатика

Ответы

radatailless
Привет! Конечно, я помогу тебе с этой программой.

Данная программа составляет одномерный массив размерностью 10, состоящий из случайных чисел в промежутке от 5 до 22. При этом элементы массива выводятся на экран в строчку.

Перед тем, как объяснить программу, давай разберемся с формулой для создания случайных чисел из заданного промежутка. Функция random(x) генерирует случайное число от 0 до x-1. Поэтому для того, чтобы получить случайное число из промежутка от a до b, мы используем формулу x := random(b-a+1) + a.

Теперь давай посмотрим на текст программы:

```
var m: array [1..10] of integer;
i: integer;
begin
for i := 1 to 10 do
begin
m[i] := Random(18) + 5;
write(m[i],' ');
end;
end.
```

1. Строка `var m: array [1..10] of integer;` объявляет массив `m` типа `integer` и размерностью 10. Это значит, что у нас будет 10 элементов в массиве.

2. Переменная `i` объявлена для того, чтобы использовать в цикле. Мы будем использовать ее как счетчик, чтобы обойти все элементы массива.

3. `begin` - означает начало блока кода. Здесь начинается цикл `for`, который будет выполняться от 1 до 10.

4. `for i := 1 to 10 do` - это цикл, который будет перебирать значения переменной i от 1 до 10 включительно. Это означает, что цикл будет выполняться 10 раз, для каждого элемента массива.

5. `begin` - снова начинается блок кода, внутри цикла.

6. `m[i] := Random(18) + 5;` - это строка, которая генерирует случайное число в промежутке от 5 до 22, и присваивает его элементу массива `m[i]`. Формула `Random(18) + 5` используется для генерации случайного числа в заданном промежутке.

7. `write(m[i],' ');` - эта строка выводит значение каждого элемента массива на экран, разделенные пробелом. Функция `write` используется для вывода значений на экран.

8. `end;` - конец блока кода внутри цикла `for`.

9. `end.` - окончание блока кода программы.

Теперь, когда мы разобрались с каждой строчкой программы, можешь попробовать запустить ее и посмотреть, что она делает. Если у тебя есть еще вопросы или нужна помощь, я с радостью помогу!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка от 5 до 22. Оформите вывод элементов на экран в строчку.Пояснение.Обратите внимание, что случайные числа задаются функцией random(x Для того чтобы задать случайные числа из промежутка от a до b есть формула x:=random(b-a+1)+a, в нашем случаеx:=random(18)+5текст программыvar m: array [1..10] of integer; i: integer;beginfor i:=1 to 10 dobeginm[i]:= Random(18)+5;write(m[i], ' ');end;end. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Shcherbinin KOLIChEVA
Остап-Лаврова1410
marketing
tsigankova2018
VladimirovichKazakova1202
Roman913
zakupka-marion
karpov68
Vyacheslavovich-Gubanov
heodbxbbshe
yurkovam-037
yana799707
many858
nadejdashin508
gorushko-tabak3