StudioArtNails
?>

Самостоятельная работа 1. Любая программа на языке С++ содержит основную программу - функцию с именем ¬¬¬¬¬¬¬¬¬¬¬¬. 2. Символами // начинается¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬, который действует до конца строки. 3. -это последовательность символов, которая поступает на вход или выход программы. 4. Основные типы данных в С++:¬¬¬¬¬¬¬¬¬¬¬¬¬ - целое число; 5. -- вещественное число; 6. - -символ; 7. - - символьная строка, 8. -- логическое значение. 9. Нарисовать блок-схему к задаче: 10. Написать программу: Ввести рост человека. Вывести на экран "высокий", если его рост превышает, 180 см и "не очень высокий" в противном случае.

Информатика

Ответы

ЕвгенияСергеевна
Тексты вводятся в память компьютера с клавиатуры. На клавишах написаны привычные нам буквы, цифры, знаки препинания и другие символы. В оперативную память они попадают в двоичном коде. Это значит, что каждый символ представляется 8-разрядным двоичным кодом.

Кодирование заключается в том, что каждому символу ставится в соответствие уникальный десятичный код от 0 до 255 или соответствующий ему двоичный код от 00000000 до 11111111. Таким образом, человек различает символы по их начертанию, а компьютер - по их коду.

Удобство побайтового кодирования символов очевидно, поскольку байт - наименьшая адресуемая часть памяти и, следовательно, процессор может обратиться к каждому символу отдельно, выполняя обработку текста. С другой стороны, 256 символов – это вполне достаточное количество для представления самой разнообразной символьной информации.

Теперь возникает вопрос, какой именно восьмиразрядный двоичный код поставить в соответствие каждому символу.

Понятно, что это дело условное, можно придумать множество кодировки.

Все символы компьютерного алфавита пронумерованы от 0 до 255. Каждому номеру соответствует восьмиразрядный двоичный код от 00000000 до 11111111. Этот код просто порядковый номер символа в двоичной системе счисления.
vikabobkova2010
Program question;

var
   a: string;
   b: integer;

begin
     writeln('Сколько тебе лет?:');
     readln(b);
     if b > 17 then begin
                                 writeln('В каком институте ты учишься?:');
                                 readln(a);
                                 writeln(a, ' хороший институт');
                                 writeln('До следующей встречи!');
                            end
          else
     if b <= 17 then begin
                                 writeln('В какой школе ты учишься?');
                                 readln(a);
                                 writeln(a, ' не плохая школа');
                                 writeln('До следующей встречи!');
                                 end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Самостоятельная работа 1. Любая программа на языке С++ содержит основную программу - функцию с именем ¬¬¬¬¬¬¬¬¬¬¬¬. 2. Символами // начинается¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬¬, который действует до конца строки. 3. -это последовательность символов, которая поступает на вход или выход программы. 4. Основные типы данных в С++:¬¬¬¬¬¬¬¬¬¬¬¬¬ - целое число; 5. -- вещественное число; 6. - -символ; 7. - - символьная строка, 8. -- логическое значение. 9. Нарисовать блок-схему к задаче: 10. Написать программу: Ввести рост человека. Вывести на экран "высокий", если его рост превышает, 180 см и "не очень высокий" в противном случае.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Reutskii884
Olgax732
Liliya-buc
fox-cab3444
Аношкина1696
zhmulyov-denis8
svetlana-ladyga
rinata542
char40
Borisovna24
mail9
snab54
fancy-decor67
Алина1564
Olga1233