shutovaa3471
?>

С ИНФОРМАТИКОЙ Составить программу нахождение минимального элемента в массиве из 15 вещественных чисел.

Информатика

Ответы

Lebedeva1577
Для примера со сложением чисел 25 учениками попробуйте проанализировать следующие ситуации: в классе всего 1 кусок мела; в классе 5 кусков мела; в классе 25 кусков мела. оцените, как от этого зависит время решения (учтите ещё ширину доски и время перемещения учеников по классу) попробуйте построить модель такого процесса. переведите эту ситуацию на язык компьютерной терминологии для многопроцессорных систем. 2) попробуйте примеры алгоритмов поиска информации в массиве и сортировки массива, которые допускают распараллеливание операций. опишите процедуру распараллеливания. сколько процессоров необходимо для эффективного распараллеливания в вами примере?
vadim1140
#include <iostream>

using namespace std;

long Factorial(int num)
{
  long res = 1;
 
  for (int i = num; i > 1; i--)
    res *= i;
  return res;
}

int NumOfElements(int **matrix, int mSize, int nSize)
{
  int res = 0;

  for (int i = 0; i < mSize; i++)
  {
    for (int j = 0; j < nSize; j++)
      if (matrix[i][j] % 2 == 0 && matrix[i][j] < 0)
        res++;
  }
  return res;
}

int main()
{
  int
    num,
    **matrix,
    mSize,
    nSize;

  cout << "Input a number: ";
  cin >> num;

  cout << num << "! = " << Factorial(num) << endl;

  cout << "Input a matrix size: ";
  cin >> mSize >> nSize;

  matrix = new int*[mSize];
  for (int i = 0; i < mSize; i++)
    matrix[i] = new int[nSize];
  for (int i = 0; i < mSize; i++)
    for (int j = 0; j < nSize; j++)
      cin >> matrix[i][j];

  cout << "Num. of the elements = " << NumOfElements(matrix, mSize, nSize) << endl;
 
  system("pause");
  return 0;
} /* End of the 'main' function */

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С ИНФОРМАТИКОЙ Составить программу нахождение минимального элемента в массиве из 15 вещественных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zdanovich90764
dmitriy
alexander4590
natalyazx151092814
guujuu
beaevgen711
Korikm
Ruslan Zarekovkin
koll23
Vyacheslavovich-Gubanov
vikashop269
Vladstreletskiy
afomin63
Tatarnikova1507
gav973