gamolml
?>

Склавиатуры вводится среднесуточная температура за октябрь определите количество дней в которые были заморозки программу надо в паскале написать

Информатика

Ответы

o-lala88387

var temp: array[1..31] of integer; k,i: integer;

beginfor i: =1 to 31 do readln(temp[i]);

for i: =1 to 31 do 

if a[i]< 0 then inc(k);

writeln(k);

end.

Kuznetsova702

program a1;

  uses crt;

  var a: array[1..31] of longint; k,i: integer;

begin

  clrscr;

  for i: =1 to 31 do begin

  write('введите температуру ',i,' числа: ');

  readln(a[i]);  

  if a[i]< 0 then k: =k+1;

  end;

writeln('  количество дней в которые были заморозки = ', k);

readln

end. 

 

p.s. если паскаль abc, то выделенное писать не обязательно 

skrepka397412
Var    a: array of integer;   i, n: integer; begin   randomize;   n : = random(10) + 1;   setlength(a, n);   writeln('исходный массив');   for i : = 0 to n-1 do begin     a[i] : = random(10);     write(a[i]: 5, ' ');   end; writeln;       writeln('возвести в квадрат');   for i : = 0 to n-1 do begin     a[i] : = sqr(a[i]);     write (a[i]: 5, ' ');   end; writeln;       writeln('заполнить степенями 2');   a[n-1] : = 1;   for i : = n-2 downto 0 do     a[i] : = a[i+1] shl 1;         for i : = 0 to n-1 do write (a[i]: 5, ' ');   writeln;       writeln ('умножить на 3 во второй половине');   for i : = n shr 1 to n-1 do     a[i] : = (a[i] shl 1) + a[i];         for i : = 0 to n-1 do write (a[i]: 5, ' ');   writeln; end.
Zhamynchiev
Class program {     static int gcd(int a, int b)     {         return b == 0 ? a : gcd(b, a % b);     }     static void main()     {         console.write("n = ");         int n = int.parse(console.;         int s = 0, p = 1, c = 0;         while (n > 0)         {             s += n % 10;             p *= n % 10;             n /= 10;             c++;         }         console.writeline("произведение: {0}", p);         console.writeline("сумма: {0}", p);         console.writeline("среднее: {0}", (double)s/c);         // вторая         console.write("p = ");         int p = int.parse(console.;         console.write("q = ");         int q = int.parse(console.;         for (int i = 2; i < = 1 + 2*(int)math.sqrt(p); i++)         {             if (q % i == 0 & & gcd(p, i) == 1)                 console.write(i + " ");         }         console.readline();     } }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуры вводится среднесуточная температура за октябрь определите количество дней в которые были заморозки программу надо в паскале написать
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

uttgroup
Алина1564
edvard-b
vallod
Владислав-Аветисян217
svetrusval
okunevo2010
arionul-secondary2
Oksana-Kirakosyan1301
vdm4275
Aleksandrovich_Mitoyan1138
matoksana
yugraspets
Serkova_Elena251
npprang21