mirdetzhuk79
?>

Написать программу которая сортирует массив по возрастанию и ищет в нем элемент равный x использовать двоичный поиск

Информатика

Ответы

sigidinv
 const nx = 20;
var x: array[1..nx, 1..nx] of integer;z:array[1..nx*2] of integer; 
i, j, k,n,r,t: integer; 
begin 
Writeln('Введите размер матрицы n');Read(n); 
 for i := 1 to n do begin   
for j := 1 to n do begin   
Read(k);x[i, j] := k;  end;end;   
Writeln('Исходный массив'); 
for i := 1 to n do begin   
for j := 1 to n do begin     
Write(x[i, j]:4);     
if x[i, j]>0 then begin t:=t+1; z[t]:=x[i, j];end;    
end;   
Writeln;  end; 
Writeln;Writeln('Одномерный массив'); 
for j := 1 to t do     
Write(z[j]:4); 
 end.
Shpunt-86
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var n:=ReadInteger('Количество элементов в массиве: ');
  var a:=ArrRandom(n,-50,50);
  a.Println(',');
  Writeln('Четные элементы: ');
  var i:=1;
  while i<n do begin Write(a[i],' '); Inc(i,2) end;
  Writeln;
  Writeln('Нечетные элементы: ');
  i:=0;
  while i<n-1 do begin Write(a[i],' '); Inc(i,2) end;
  Writeln
end.

Тестовое решение:
Количество элементов в массиве:  10
15,-18,-29,-25,46,21,-8,-17,-9,15
Четные элементы:
-18 -25 21 -17 15
Нечетные элементы:
15 -29 46 -8 -9

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая сортирует массив по возрастанию и ищет в нем элемент равный x использовать двоичный поиск
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

myxa120283
Kuzina Sergeevna
morozova
krisrespect2
elenaneretina
Дарья16
Lerkinm
tatry2005
StudioArtNails
sevro3038
Larax0819
ngz55
stusha78938
anadtacia03108988
Aleksei806
▲