alvas12828646
?>

Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число. Найти сумму и произведение его цифр.

Информатика

Ответы

Valentinovna

#include <iostream>

int main()

{

int N, s1 = 0, s2 = 1;

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

std::cin >> N;

while (N > 0)

{

 s1 += N % 10;

 s2 *= N % 10;

 N /= 10;

}

std::cout << "Сумма: " << s1 << std::endl;

std::cout << "Произведение: " << s2;

return 0;

}

dsnewline

1.    Он американский ученый, основоположник кибернетики. А

также теории об искусственном интеллекте. Славу ему принесли его работы в

математике и физике. Его большая роль в том, что именно он впервые смог понять

огромное значение того, что информация будет использоваться в процессах

управления.


2.      

Основатель теории информации, которая нашла свое место в современных

системах связи. В 40-х годах века ввел понятие «бит».


3.      

Термин, который означает «выполняющееся

действие по запросу», ввел Тед Нельсон в веке, в 1963 году.


4.      

В 1989 году. Изобретателем считают

двух человек – Тима Бернерс-Ли и Роберт Кайо.


5.      

Эйлер, в честь которого назвали графическую

схему, был ученым. Его сферой изучения была математика, физика, астрономия,

химия, ботаника, музыка, медицина и другие направления. Он автор 600 трудов. 


не за что!       и на сердечко

rmitin

1. Норберт Винер - американский ученый, основоположник кибернетики и теории искусственного интеллекта. У него была идея о необходимости  создании единой науки, изучающей процессы хранения и переработки информации, управления и контроля.

2.Клод Шеннон - американский инженер, является основателем теории информации, нашедшие применения в современных высокотехнологических системах связи. Предложил использовать слово бит для обозначения информации.

3. В 1962 году, был придуман Тедом Нельсоном, а опубликован в 1965 году

4. Официально годом рождения WWW можно считать 1989 год. Изобретатель Тим Бернс-Ли

5.Эйлер- ученый математик,астроном,  родился в 1707 году в семье базельского пастора Пауля Эйлера

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число. Найти сумму и произведение его цифр.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

molchanovaelena284
Tkachenko1050
eugene869154
frame45
pavlova7771960
makitra08
Yurevich
Rjkjneirbyf555
tatianamatsimoh
monenko
Feyruz90
ortopediya
Вячеславович-Дмитрий1694
Igorevich_Aleksandrovna1599
Александра-Андрей909