mospaskrasnogorbukh
?>

Продолжите предложение. Информатика это 1)умение обращение с компьтеров 2)наука об информации и её хранения обработки и передачи с копьютера 3)умение составлять компьютерные программы 4)сведения об окружающем мире

Информатика

Ответы

allo22-27

2) Наука об информации и её хранения обработки и передачи с копьютера

Объяснение:

Andrei_Mariya
Const
    N = 10;

var
    A: array[1..N] of integer;

function Fun: integer;
var
    i, M: integer;
begin
    writeln('Введите число M=');
    readln(M);
    for i := 1 to N do
        if A[i] = M then Fun := i;
end;

procedure CreateMassive;
var
    i: integer;
begin
    for i := 1 to N do
    begin
        A[i] := Random(199) - 100;
        write(A[i],' ');
    end;
    Writeln;
end;

begin
    CreateMassive;
    Writeln(Fun);
end.

вот вариант исправления который работает, хотя конечно не факт что он работает как там кто-то задумывал)))
не понятно было назначение функции Fun потому она делает поиск номера элемента равного М
а вообще глобальные переменные это зло. Так что проектирование тут в корне не верно
anechcak
Собственно чтобы представить число в двоичную систему счисления, необходимо разделить его на максимально целую часть, которая при умножении на 2 давала нам ближайшее значение к этому числу. Т.е.
число 243: если мы умножим 121 на 2: 121*2=242;Т.е. 121 умноженное на 2 и есть ближайшее число к 243, но им не является, т.к. остаток 1, мы записываем его ниже и делим число дальше. Вспоминаем деление столбиком и высчитываем (во вложении). Также, есть более быстрое и продуктивное высчитывание (во вложении). В обоих решениях выписывание остатков происходит в обратном порядке для верного ответа.
Сколько единиц в двоичной записи десятичного числа 243

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Продолжите предложение. Информатика это 1)умение обращение с компьтеров 2)наука об информации и её хранения обработки и передачи с копьютера 3)умение составлять компьютерные программы 4)сведения об окружающем мире
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kazimov832
korj8
Yelena_Irina826
Kotvitskii
ank9809
almihanika435
Грачева мураховская
ОвчинниковаТатьяна
tkmandarin8376
Alekseeva_Khlistov
oksanata777
peshnoshamon
Dmitriy793
aetolstih
aetolstih