rusdtver
?>

Напишите программу, которая получает случайное целое число- 0 или 1, а затем выводит цепочку из 10 знаков "-", если получено число 0, и цепочку из 10 знаков "+", если получено число 1. Пример: Случайное число 0 случайное число 1

Информатика

Ответы

Daulyatyanov1266
я не знаю, сори. нужны баллы
я не знаю, сори. нужны баллы
я не знаю, сори. нужны баллы
я не знаю, сори. нужны баллы
.
.
.
.
.
я не знаю, сори. нужны баллы
most315
1)
var s:string;
     i:integer;
     f:boolean;
begin
  f:=false;
  write ('S = ');
  readln(s);
  for i:=1 to length(s) div 2 do
   if s[i]=s[length(s)-i+1] then f:=true else 
    begin
      f:=false;
      break;
    end;
  if f then writeln ('PALINDROM') else writeln ('NOT PALINDROM');
  readln;
end.

2)
var a,b:integer;
     count,j:integer;
function palindr (n:integer):boolean;
var s:string;
     i:integer;
begin
  palindr:=false;
  str (n,s);
    for i:=1 to length(s) div 2 do   
      if s[i]=s[length(s)-i+1] then palindr:=true else
        begin
           palindr:=false;
           break;
        end;
end;
begin
  write ('A = ');
  readln(a);
  write ('B = ');
  readln(b);
  count:=0;
  for j:=a to b do
    if palindr(j) then
     begin
       write (j,' ');
       count:=count+1;
     end;
  writeln;
  writeln ('Kol-vo palindromov: ',count);
  readln;
end.
megapolisgroup
Если Вы ранее пользовались интернетом и все было нормально, то следует проверить компьютер на вирусы. Возможно  антивирусная программа попросту устарела. Тогда, следует обновить антивирусную программу или установить новую. Если же вирусов нет, то проверьте качество сети, иногда браузеры выдают аварийную ошибку, когда прерывается связь. Это можно легко определить, на модеме будет часто и прерывисто мигать лампочка (если у вас модем допустим мегафон или что-то подобное), на стационарном модеме, подключенном к телефону, потухнет или будет гореть красным знак "собаки". 
Когда вы убедились, что с Вашей стороны все в порядке. то вы имеете право обратиться в "Центр управления сетями и общим доступом", или обратиться по телефону, указанному в договоре с компанией представителем услуг, с сообщением о неисправности сети. В указанный  срок они обязаны устранить неполадки.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая получает случайное целое число- 0 или 1, а затем выводит цепочку из 10 знаков "-", если получено число 0, и цепочку из 10 знаков "+", если получено число 1. Пример: Случайное число 0 случайное число 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vusokaya13
masamosijcuk140244
Хромов1501
balabina-Olesya
olofinskayae
office46
ВостриковаСтародубцева1980
teya07
ИринаАлександровна
artemy682719
Natalya1895
lera4075
zakup-r51
dmitryshigin
marinavg63607
▲