Елена
?>

PYTHON. Задания по теме «Ветвление» Задача № 1 Даны три целых числа. Выбрать из них те, которые принадлежат интервалу [1, 3]. Задача № 2 Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. Задача № 3 Вывести на экран синус максимального из 3 заданных чисел. Задача № 4 Составить программу, которая по данному числу (1-12) выводит название соответствующего ему месяца. Задача № 5 Дано три числа. Найти количество положительных чисел среди них; Задача № 6 Если действительные числа x и y – одного знака, найти их среднее геометрическое, в противном случае найти их среднее арифметическое. Задача № 7 Определить, существует ли треугольник с длинами сторон a, b, c. Если – да, вычислить его площадь по формуле Герона. Формула Герона имеет вид: S=p(p-a)(p-b)(p-c), где p=1/2(a+b+c)​

Информатика

Ответы

rinat

С бит можно закодировать 2^32 = 4294967296 символов (похоже на ощибку в условии задачи)

 

С бит можно закодировать2^10 = 1024 вариантов.

 

1/512 Мбайт = (1024*1024)/512 байт = 2048 байт.
2048/2048 = 1 байт - нужен для кодировки одного символа
1 байт = 8 бит - информационный вес одного символа
С бит можно закодировать 2^8 = 256 символов - это и есть размер алфавита

 

Всего двузначных чисел 90. Чтоб закодировать 90 чисел, нужно 7 бит (2^7=128). Значит каждое двузначное число несёт 7 бит информации

 

2^9 = 512 - чтоб закодировать 512 номеров страниц, нужно 9 бит. Сообщение о местопоожении закладки содержит 9 бит

 

Qw - к-во белых банок
Qb - к-во синих банок
Qr - к-во коричневых банок
Iw=log2(1/Рw)
2= log2(1/Pw)
1/Pw=4
Pw=1/4  -  вероятность расхода белой банки;
N = Qw/Pw = 8/(1/4) = 32  - банoк с краской было всего
Qr = N - Qw – Qb = 32 – 8 – 8 = 16 - банок коричневой краски

 

Пусть вероятности того, что выпадет определённая грань, будут такие:
р1 = 1/2,
р2 = 1/4,
р3 = 1/8,
р4 = 1/8,
тогда к-во информации, получаемой после одного из этих событий, рассчитывается по формуле Шеннона:
I = - \sum p_i* log_2 p_i\\ I = -(1/2 log_2 1/2 + 1/4 log_2 1/4 + \\ +1/8 log_2 1/8 + 1/8 log_2 1/8) =\\= 1/2 + 2/4 + 3/8 + 3/8 = 14/8 = 1,75(бит).

 

Bni1504

 


Program Polik1907;
uses crt;
Var
  tur:real;
  mes:integer;
begin
  writeln('');
  writeln('*    Мы рады приветствовать вас       *');
  writeln('*         в нашем турагентстве        *');
  writeln('*         P O L I K   1 9 0 7         *');
  writeln('*               ! ! !                 *');
  writeln('');
  writeln();
  writeln('Введите базовую стоимость путёвки: ');
  readln(tur);
  writeln('month Введите номер месяца: ');
  readln(mes);
  case mes of
    1,5,10: writeln('Стоимость вашей путёвки составит ',tur,'  рублей');
    6,7,8,9:  writeln('Стоимость вашей путёвки составит ',tur*1.2,'  рублей');
    2,3,4,11,12:  writeln('Стоимость вашей путёвки составит ',tur*0.8,'  рублей');
    else writeln('Введите правильный номер месяца');
  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PYTHON. Задания по теме «Ветвление» Задача № 1 Даны три целых числа. Выбрать из них те, которые принадлежат интервалу [1, 3]. Задача № 2 Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. Задача № 3 Вывести на экран синус максимального из 3 заданных чисел. Задача № 4 Составить программу, которая по данному числу (1-12) выводит название соответствующего ему месяца. Задача № 5 Дано три числа. Найти количество положительных чисел среди них; Задача № 6 Если действительные числа x и y – одного знака, найти их среднее геометрическое, в противном случае найти их среднее арифметическое. Задача № 7 Определить, существует ли треугольник с длинами сторон a, b, c. Если – да, вычислить его площадь по формуле Герона. Формула Герона имеет вид: S=p(p-a)(p-b)(p-c), где p=1/2(a+b+c)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sochi-expert
fucksyara
Андрей Шитенкова
daverkieva568
mihailpolehin8
proplenkusale88
nataliaprintroll
vikapar2646
egoryandiana3727283
Aleksandrovich1415
maryshecka
Исакова-Александрович511
oldprince840
mansur071199486
olofinskayae