filippovev1
?>

Напишите программу, которая запрашивает координаты точки на плоскости и выводит сообщение о том, принадлежит ли данная точка заштрихованной области

Информатика

Ответы

hachatryanlilit1983
Вот задача для "троечников" с дополнительной оценкой:

program pr1;
uses
crt;

const
arr1 : array[1..12] of integer = (5, 4, -3, 1, 0, -4, 0, 25, -8, 0, -17, -1);

type
arr2 = array of integer;

var
arr : arr2;
n : integer;
i, sot, spl, snu : byte;
ch : char;

begin
write('Хотите использовать заданный по умолчанию массив? (y/n): ');
ch := readkey;
writeln(ch);
sot := 0;
spl := 0;
snu := 0;
if ((ch='y') or (ch='Y')) then begin
{ Используем заданный по умолчанию }
for i:=1 to 12 do begin
if arr1[i] > 0 then inc(spl);
if arr1[i] < 0 then inc(sot);
if arr1[i] = 0 then inc(snu);
write(arr1[i], ' ');
end;
writeln;
end
else begin
{ Создаём и заполняем новый массив }
write('Введите желаемый размер массива: ');
readln(n);
setLength(arr, n);
writeln('Введите элементы массива:');
for i:=0 to high(arr) do
readln(arr[i]);
for i:=0 to high(arr) do begin
if arr[i]>0 then inc(spl);
if arr[i]<0 then inc(sot);
if arr[i]=0 then inc(snu);
write(arr[i], ' ');
end;
writeln;
end;

writeln('Количество отрицательных элементов: ', sot);
writeln('Количество нулевых элементов: ', snu);
writeln('Количество положительных элементов: ', spl);
end.
Yevgenevich
Не трудно, но не полностью условие выполнено. Лови решение:

program arrs;
var
a : array[1..26] of integer;
i, min, max : integer;
m1, m2 : byte;

begin
randomize;
for i:=1 to 26 do begin
a[i] := random(29)-15;
write(a[i], ' ');
end;
min := 15;
max := -20;
for i:=1 to 26 do begin
if a[i] < min then begin
min:=a[i];
m1 := i;
end;
if a[i] > max then begin
max:=a[i];
m2 := i;
end;
end;
writeln;
writeln('Минимальный элемент в ячейке ', m1, ' равен ', min);
writeln('Максимальный элемент в ячейке ', m2, ' равен ', max);
end.

тестовый прогон:

0 2 -1 2 -9 -13 -9 -5 0 -14 11 6 8 -11 13 3 -15 -6 -15 -14 -3 13 9 7 3 -4
Минимальный элемент в ячейке 17 равен -15
Максимальный элемент в ячейке 15 равен 13

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая запрашивает координаты точки на плоскости и выводит сообщение о том, принадлежит ли данная точка заштрихованной области
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

d892644813661946
mmihail146
Verdievruslan
whitecatrussia5398
mustaevdmitry397
mstapottery
Li-111
Cannabikh
bel1-79
Talikova164
vitalina3012
Valerevna-Vardan
maksteks
shkola8gbr
Aleksandrovich1669