mansur071199486
?>

Решите задачу в python быстрее! — А разве ещё что-нибудь есть? — с надеждой с Пух, снова оживляясь. Кролик заглянул во все кастрюли и банки и со вздохом сказал: — Увы, совсем ничего не осталось. — Я так и думал, — сочувственно сказал Пух, покачав головой. — Ну, до свиданья, мне пора идти. Как вы помните, из этого ничего не вышло. Он застрял! А если отмотать события немного назад, сколько можно было съесть, чтобы все-таки пролезть в дверь? Напишите программу, которая определит, на сколько единиц ещё можно увеличить объем Винни-Пуха, чтобы он не застрял. Формат ввода Целое число — на сколько единиц можно увеличить объем Винни Пуха, чтобы он ещё пролез в дверь. Затем строки мёд, сгущенное молоко или хлеб, пока не будет введена строка Ничего не осталось. Формат вывода Считая, что мёд увеличивает объем на 1 единицу, сгущённое молоко на две, а хлеб на три, вывести, сколько ещё единиц осталось до критического значения, или строку Не пролезает. Если значение оказалось равно критическому, то осталось 0 единиц, но всё ещё пролезает. Пример 1 Ввод Вывод 7 мёд сгущенное молоко мёд Ничего не осталось 3 Пример 2 Ввод Вывод 1 хлеб Ничего не осталось Не пролезает

Информатика

Ответы

irinaastapova2011
Program schet;
var a:integer;
label h;
begin
h:
begin
writeln('Введите количество палочек: ');
readln(a);
if (a<=0) then goto h 
else
a:=a+3;
writeln('У Тани стало ', a, ' палочек');
end;
readln;
end.

Program schet;
var a,b:integer;
begin
a:=2015;
writeln('Сколько лет проводится олимпиада?');
readln(b);
a:=a-b;
writeln('Первая олимпиада была проведена в ',a,' году.');
readln;
end.

Program schet;
var a,b,c,i:integer;
begin
writeln('Сколько семечек посадил Пятачок?');
readln(a);
writeln('Сколько семечек не выросло?');
readln(b);
a:=a-b;
writeln('Сколько не плодоносных яблонь?');
readln(c);
a:=a-c;
writeln('На скольки яблонях вкусные яблоки?');
readln(i);
a:=a-i;
if (a<0) then writeln('Выросло 0 яблонь с невкусными яблоками.')
else writeln('Выросло ',a,' яблонь с невкусными яблоками.');
readln;
end.

Program schet;
var a:real;
begin
writeln('Введите число, которое нужно округлить:');
readln(a);
a:=round(a);
writeln('ответ после округления: ',a);
readln;
end.
Геннадьевич-Тимофеева158
{Заполнить двумерный массив N x N случайными числами из интервала [-10 ; 10], выяснить что больше сумма элементов лежащих над главной диагональю или под главной диагональю.}const nmax = 20;var A:Array[1..nmax,1..nmax] of integer; n,m,i,j,sumN,sumV:integer;
beginwrite('Введите число n');readln(n);for i:=1 to n do beginfor j:=1 to n do beginm:= random(20)-10;A[i,j]:= m;write(A[i,j]:4);end;writeln;end;
writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i>j then begin write(A[i,j]:4);sumN:= sumN + A[i,j];end;end;writeln;end;
writeln;writeln;
for i:=1 to n do beginfor j:=1 to n do beginif i < j then begin write(A[i,j]:4);sumV:= sumV + A[i,j];end;
end;writeln;end;if sumN > sumV then write('Cумма элементов лежащих под главной диагональю больше')else write('Cумма элементов лежащих над главной диагональю больше');end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите задачу в python быстрее! — А разве ещё что-нибудь есть? — с надеждой с Пух, снова оживляясь. Кролик заглянул во все кастрюли и банки и со вздохом сказал: — Увы, совсем ничего не осталось. — Я так и думал, — сочувственно сказал Пух, покачав головой. — Ну, до свиданья, мне пора идти. Как вы помните, из этого ничего не вышло. Он застрял! А если отмотать события немного назад, сколько можно было съесть, чтобы все-таки пролезть в дверь? Напишите программу, которая определит, на сколько единиц ещё можно увеличить объем Винни-Пуха, чтобы он не застрял. Формат ввода Целое число — на сколько единиц можно увеличить объем Винни Пуха, чтобы он ещё пролез в дверь. Затем строки мёд, сгущенное молоко или хлеб, пока не будет введена строка Ничего не осталось. Формат вывода Считая, что мёд увеличивает объем на 1 единицу, сгущённое молоко на две, а хлеб на три, вывести, сколько ещё единиц осталось до критического значения, или строку Не пролезает. Если значение оказалось равно критическому, то осталось 0 единиц, но всё ещё пролезает. Пример 1 Ввод Вывод 7 мёд сгущенное молоко мёд Ничего не осталось 3 Пример 2 Ввод Вывод 1 хлеб Ничего не осталось Не пролезает
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zakupka-marion
irinakiral
Kati2005
AMR89154331531
kazanoop
Latsukirina
maryariazantseva
Виктор-Богданов
Как создать сайт для 8 классника
mototeh69
Сергеевна-Пузанов
jim2k
mikhail
Immortal3331
Марина555
matterfixed343
▲