Vladimirovich-Aleksandrovna96
?>

Дано целое число х и натуральное n.составьте алгоритм вычисления x в n степени.прооверьте алгоритм трассировкой.напишите программу на языке паскаль.

Информатика

Ответы

зырянов_Юрьевна378

если числа небольшие и x в n степени умещается в longint, то можно в цикле от 1 до n умножать на x

 

var i,x,n: integer;

l: longint;

 

begin

readln(x,n);  

l: =1;  

for i: =1 to n do

l: =l*x;

write(l);

end.  

zakaz1
Var x1,y1,x2,y2,d1,d2: real; begin   write ('x1 = ');   readln (x1);   write ('y1 = ');   readln (y1);   write ('x2 = ');   readln (x2);   write ('y2 = ');   readln (y2);   d1: =sqrt(sqr(x1)+sqr(y1));   d2: =sqrt(sqr(x2)+sqr(y2));   if d1< > d2 then write ('к началу координат ближе ');     if d1> d2 then writeln ('вторая точка') else       if d2> d1 then writeln ('первая точка') else           writeln ('обе точки равноудалены друг от друга'); end.
fedserv

uses graph; var n,i,x,y,height,width: integer; procedure init; var gd,gm: integer; begin  gd: =vga;   gm: =vgahi;   initgraph (gd,gm,''); end; procedure error; begin  closegraph;   writeln ('error! '); end; begin  write ('n = ');   readln (n);   randomize;   init;   if graphresult = 0 then      begin          for i: =1 to n do              begin

                  setcolor (random(14)+1);                   x: =random(640);                   y: =random(480);                   height: =random(91)+10;                   width: =random(101)+20;                   rectangle (x,y,x+width,y+height);               end;       end else error; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано целое число х и натуральное n.составьте алгоритм вычисления x в n степени.прооверьте алгоритм трассировкой.напишите программу на языке паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*