Bella Sergei
?>

Напишите программу на паскаль с клавиатуры вводится натуральное число n>0, потом n чисел, каждое на новой строке. Вычислите и напечатайте знакочередующуюся сумму ряда (первое число прибавить, второе вычесть, третье прибавить и т.д.) Например, для чисел 1, 2, 3, 4 сумма будет следующей: 1-2+3-4=-2

Информатика

Ответы

mv7095

n = int(input())

b = 0

for i in range(n):

   a = int(input())

   if i % 2 == 0:

       b += a

   else:

       b -= a

print(b)

Объяснение:

KovalenkoIL

17 байт

Объяснение:

Разбираемся с личным кодом:

Длина n=11 символов

15 букв + 10 цифр = 25 символов - мощность алфавита личного кода.

25 \le 2 ^ {i}, где i - кол-во бит на символ

i = 5 бит (из неравенства выше)

V = i * n = 5 бит * 11 = 55 бит ≤ 7 байт

Разбираемся с кодом подразделения:

Длина n=8 символов

26 букв + 10 цифр = 36 символов - мощность алфавита кода подразделения

36 \le 2 ^ {i}

i = 6 бит

V = 8 * 6 бит = 48 бит ≤ 6 байт

Итого объем кодов в сумме равен V=7 + 6 байт = 13 байт

Объем хранящийся на пропуске равен 30 байтам

Объем доп информации 30 байт - 13 байт = 17 байт

Valentinovna

117.725°, 23.8109°, 38.4643°

Объяснение:

Можно использовать теорему косинусов:

c^2=a^2+b^2-2ab\cos\gamma\\\cos\gamma=\dfrac{a^2+b^2-c^2}{2ab}

Считаем такие дроби, берем арккосинус, получаем угол в радианах. Можно умножить на 180/π, тогда получится угол в градусах.

По-хорошему, можно определить функцию, которая будет вычислять угол, тогда код будет опрятнее, понятнее, и в неём будет сложнее допустить ошибку. Но я этого делать не буду :)

Код (C++):

#define _USE_MATH_DEFINES

#include <iostream>

#include <cmath>

int main() {

 double a, b, c;

 std::cin >> a >> b >> c;

 std::cout << acos((a * a + b * b - c * c)/(2 * a * b)) * 180/M_PI << " ";

 std::cout << acos((c * c + b * b - a * a)/(2 * c * b)) * 180/M_PI << " ";

 std::cout << acos((a * a + c * c - b * b)/(2 * a * c)) * 180/M_PI << " ";

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскаль с клавиатуры вводится натуральное число n>0, потом n чисел, каждое на новой строке. Вычислите и напечатайте знакочередующуюся сумму ряда (первое число прибавить, второе вычесть, третье прибавить и т.д.) Например, для чисел 1, 2, 3, 4 сумма будет следующей: 1-2+3-4=-2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

moskvichkabakery56
viktort889841
bulin2001
missbuhgalter2013
dmitryshigin
tooltechnic
Tuzov
Кристина Валентиновна
agaloan8
cleopatra1959
fishka-sokol14
Nadegdasb
bei07
Li-111
Борисовна_Кашутина
▲