irohmichaelchikaodiri
?>

Ребята Вычислить по действиям значение выражения: а) 5+(20mod7)/3- SQR(25)= б) SQRT (64) div 2 - (18 mod 5) = 2) Записать на языке Паскаль: y=sin2x- 21-x 3) Запишите число, которое будет выведено в результате работы фрагмента программы: n := 0; s := 200; while s > 0 do begin s := s - 15; n := n + 3; end; write(n) 4)Определите значение переменной «s» после выполнения следующего фрагмента программы: s:=0; for k:=1 to 3 do begin for j:=1 to k do s:=s+k+j; end; 5) Исполнитель КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера: 1)Прибавь 7 2)Раздели на 4 Напишите программу, содержащую не более 5 команд, которая из числа 13 получает число 10. Укажите лишь номера команд.

Информатика

Ответы

detymira
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var x:=-2.0;
  while x<=2 do begin
    Writeln('x=',x:4:1,' y=',x*x*x+12:6:3);
    x+=0.2
    end
end.

Результат выполнения программы:
x=-2.0 y= 4.000
x=-1.8 y= 6.168
x=-1.6 y= 7.904
x=-1.4 y= 9.256
x=-1.2 y=10.272
x=-1.0 y=11.000
x=-0.8 y=11.488
x=-0.6 y=11.784
x=-0.4 y=11.936
x=-0.2 y=11.992
x= 0.0 y=12.000
x= 0.2 y=12.008
x= 0.4 y=12.064
x= 0.6 y=12.216
x= 0.8 y=12.512
x= 1.0 y=13.000
x= 1.2 y=13.728
x= 1.4 y=14.744
x= 1.6 y=16.096
x= 1.8 y=17.832
x= 2.0 y=20.000
akudryashov

1.B

2.

а) на первом растровое изображение(не уверен), а на втором векторное

б)

преимущества растровой графики:

лучше подходит для детализированных картинок(фото, картины и т.п.)

преимущества векторной графики:

легко масштабируется без потери качества.

предназначена для не замысловатой графики (логотипы, иконки во flat стиле и т.п.)

в случае с простой графикой имеет небольшой вес

недостатки растровой графики:

неоправданно большой вес в случае с простой картинкой по сравнению с векторной графикой.

плохо масштабируется

недостатки векторной графики:

1. абсолютно не подходит для хранения фото

2. (высосано из пальца)для вывода на дисплей все равно нужно преобразовать векторную картинку в растровую, в связи с природой мониторов.(не сказал бы, что критично, ведь большую часть времени картинка просто хранится на компьютере и все ее преимущество в масштабирований и размере. И вообще в современных компьютерах на преобразование уходят миллисекунды, еще потом преобразованная картинка хранится в ОЗУ, и на преобразование не уходит времени.)

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ребята Вычислить по действиям значение выражения: а) 5+(20mod7)/3- SQR(25)= б) SQRT (64) div 2 - (18 mod 5) = 2) Записать на языке Паскаль: y=sin2x- 21-x 3) Запишите число, которое будет выведено в результате работы фрагмента программы: n := 0; s := 200; while s > 0 do begin s := s - 15; n := n + 3; end; write(n) 4)Определите значение переменной «s» после выполнения следующего фрагмента программы: s:=0; for k:=1 to 3 do begin for j:=1 to k do s:=s+k+j; end; 5) Исполнитель КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера: 1)Прибавь 7 2)Раздели на 4 Напишите программу, содержащую не более 5 команд, которая из числа 13 получает число 10. Укажите лишь номера команд.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alekseysokolov29816
yugraspets
Pavlushina-Novikova
Aleksandr740
fedotochkin8
suny84
djikia88
dmitryshigin
sargisyan
blagorodovaanna375
mstrshulz
morozmd
Umkatoys50
gip5362
Анна Марина1873
▲