stendpost
?>

с информатикой умоляю, Составьте программу вычисления количества корней для каждого из трех квадратных уравнений с данными коэффициентами, используя подпрограмму вычисления количества корней квадратного уравнения Ax2+Bx+C=0 (A, B, C - вещественные параметры, А<>0) по значению дискриминанта D:=b2-4ac. Протокол работы программы: A1= 3.00 B1= -15.00 C1= 12.00 A2= 1.00 B2= -3.00 C2= 3.00 A3= 1.00 B3= 5.00 C3= 7.00 количество корней первого уравнения = 2 количество корней второго уравнения = 0 количество корней третьего уравнения = 0

Информатика

Ответы

verachus

Не бейте, я не знаю, что я написал. Надеюсь, тебе это .

#include <iostream>

#include <vector>

using namespace std;

template<typename a, typename b>

class myPair {

public:

myPair(a first, b second) : first(first), second(second) {

}

myPair operator+(myPair a) {

 return myPair(first + a.first, second + a.second);

}

myPair operator-(myPair a) {

 return operator+(myPair(-a.first, -a.second));

}

a first;

b second;

};

class complex : myPair<int, int> {

public:

friend myPair;

complex(int real, int imaginary) : myPair(real, imaginary) {

 

}

int real() {

 return first;

}

int imaginary() {

 return second;

}

complex operator+(complex a) {

 return complex(myPair::operator+(a).first, myPair::operator+(a).second);

}

complex operator-(complex a) {

 return complex(myPair::operator-(a).first, myPair::operator-(a).second);

}

complex operator*(complex a) {

 return complex(real() * a.real(), imaginary() * a.imaginary());

}

};

int main() {

complex a(1, 2), b(10, 11);

cout << (a + b).real() << " " << (a + b).imaginary() << " " << (a - b).real() << " " << (a - b).imaginary() << " " << (a * b).real() << " " << (a * b).imaginary();

}

N-odes-art-school410

n = int(input('Введите натуральное число:'))

count = 0

count_multiple = 0

numbers = []

while count_multiple < 1000 and n != 0:

   if n > 30000:

       print('Вы ввели число больше 30000! Попробуйте еще раз')

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

   elif n % 5 == 0:

       numbers.append(n)

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

       count += 1

   else:

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

print(f'количество чисел кратных пяти = {count}')

Объяснение:

Python


11) напишите программу, которая в последовательности натуральных чисел определяет количество всех чё

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с информатикой умоляю, Составьте программу вычисления количества корней для каждого из трех квадратных уравнений с данными коэффициентами, используя подпрограмму вычисления количества корней квадратного уравнения Ax2+Bx+C=0 (A, B, C - вещественные параметры, А<>0) по значению дискриминанта D:=b2-4ac. Протокол работы программы: A1= 3.00 B1= -15.00 C1= 12.00 A2= 1.00 B2= -3.00 C2= 3.00 A3= 1.00 B3= 5.00 C3= 7.00 количество корней первого уравнения = 2 количество корней второго уравнения = 0 количество корней третьего уравнения = 0
Ваше имя (никнейм)*
Email*
Комментарий*