themolodoy
?>

Для заданного х, введенного с клавиатуры, вычислить y по формуле: y=√2 x−1.5+14 x2 (знак квадратного корня до 1.5) Нужно написать программу для вычисления Язык программирования Паскаль

Информатика

Ответы

Wlad967857

по вертикали

1. Система из текстовых страниц, имеющих перекрёстные ссылки, составленные как по вертикали, так и по горизонтали это?

2. Волна с непрерывно изменяющейся амплитудой и частотой это ?

5. Технические приёмы создания иллюзии движущихся изображений с последовательности неподвижных изображений (кадров) это?

7. Электронная плата, которая позволяет записывать звук, воспроизводить его и создавать программными средствами с микрофона, наушников, динамиков, встроенного синтезатора и другого оборудования это?

8. Технология обработки, структурирования информации и произвольного доступа к её элементам с гиперсвязей это?

10. Деятельность по проектированию эстетических свойств промышленных изделий , а также результат этой деятельности это?

по горизонтали

3. Совокупность движущихся изображений (монтажных кадров), связанных единым сюжетом это ?

4. Часть гипертекстового документа, ссылающаяся на элемент в этом документе , или на другой объект, , расположенный на локальном диске или в компьютерной сети, либо на элементы этого объекта это?

6. Документ или комплект документов, предназначенный для представления чего-либо это?

9. Данные, или содержание, которые представляются одновременно в разных формах: звук, анимированная компьютерная графика, видеоряд это?

11. Преобразование непрерывного сигнала в последовательность чисел это?

12. Метод описания поискового запроса с использованием метасимволов («*» — любая последовательность символов (слово), «?» — любой символ)

AndreiFaikov1943
// Использование указателей для создания односвязного списка
// Сделано на базе демонстрационного примера PascalABC.Net
//
// PascalABC.NET 3.2, сборка 1325 от 19.10.2016
type
  PNode=^TNode;
  TNode=record
    data:integer;
    next:PNode;
  end;

function NewNode(d:integer;n:PNode):PNode;
begin
  New(Result);
  Result^.data:=d;
  Result^.next:=n;
end;

procedure WriteNode(a:PNode);
// Вывод односвязного списка
begin
  Writeln('Содержимое односвязного списка: ');
  var p:=a;
  while p<>nil do begin
    Write(p^.data,' ');
    p:=p^.next;
    end;
  Writeln
end;

function SeekNode(k:integer;a:PNode):PNode;
// Поиск элемента со значением k в списке
begin
  var p:=a;
  Result:=Nil;
  while p<>nil do begin
    if p^.data=k then begin Result:=p; break end;
    p:=p^.next
    end
end;

function PredNode(a,f:PNode):PNode;
// Поиск предшественника f среди a
begin
  var p:=a;
  while p^.next<>f do p:=p^.next;
  Result:=p
end;

procedure Clear(a:pNode);
// Разрушение односвязного списка
begin
  var p:=a;
  while p<>nil do begin
    var p1:=p;
    p:=p^.next;
    Dispose(p1); // Память обязательно возвращать
    end
end;

var
  first,found,father,grandfather,greatgrandfather:PNode;
 
begin
  Randomize;
  first:=nil;
  for var i:=1 to 10 do
    first:=NewNode(Random(100),first);
  WriteNode(first); // первоначальное состояние списка
  var k:=ReadInteger('Введите число для поиска в списке');
  found:=SeekNode(k,first);
  if found<>nil then begin
    father:=PredNode(first,found); // отец
    grandfather:=PredNode(first,father); // дед
    greatgrandfather:=PredNode(first,grandfather); // прадед
    greatgrandfather^.next:=father;
    Writeln('Элемент ',grandfather^.data, ' удален');
    Dispose(grandfather);
    WriteNode(first);
    k:=ReadInteger('Введите число для вставки');
    father^.next:=NewNode(k,found);
    WriteNode(first);
    end
  else Writeln('Такого числа в списке нет');
  Clear(first)
end.  

Пример
Содержимое односвязного списка:
11 75 44 86 88 83 92 18 4 23
Введите число для поиска в списке 88
Элемент 44 удален
Содержимое односвязного списка:
11 75 86 88 83 92 18 4 23
Введите число для вставки 40
Содержимое односвязного списка:
11 75 86 40 88 83 92 18 4 23

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Для заданного х, введенного с клавиатуры, вычислить y по формуле: y=√2 x−1.5+14 x2 (знак квадратного корня до 1.5) Нужно написать программу для вычисления Язык программирования Паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

chuev4444
websorokin
Aleksandr_Vasilev
levickaalubov5
BekturMagometovich189
artemiusst
Лилия-Карпухина337
Segyn1218
Azarova Anastasiya1707
dentinnsmr467
zrs-546
ВладимировнаИП37
taksa6444
esnails17
manyugina1