Yeremeev
?>

нужна ваша решение на языке паскаль На обработку поступает натуральное число, не превышающее 10^9. Нужно написать программу, которая выводит на экран сумму нечетных цифр числа, которые делятся на 3. Если в числе нет таких цифр, требуется на экран вывести «NO».

Информатика

Ответы

lubavarif83

program z1;

var a,s: longint;

begin

write ('Введите число: ');

readln(a);

s:=0;

repeat

if (a mod 10 mod 2 = 1) and (a mod 10 mod 3 = 0) then s:=s+a mod 10;

a:=a div 10

until a=0;

if s = 0 then write('NO')

else writeln(s)

end.

Энверович
Уровень A.

1. Процессор;
2. Тачпад;
3. Floppy disk;
4. Файл;
5. На тип данных, хранящихся в нем;
6. Презентация;
7. rtf, doc, docx, txt;
8. Служит для размещения данных и промежуточных результатов вычислений в процессе работы ПК, а также размещения программ;
9. Комплекс программ ПК, управляющих его работой и обеспечивающих эффективное использование ресурсов системы;
10. На системное, прикладное, системы программирования;

Уровень B.

1. fami-ly.jpg, car.bmp, dog.gif;
2. Монитор, принтер, клавиатура, флэш-память, колонки;
3. Дискета, CD-ROM, DVD-ROM, жесткий диск;
4. Принтер, колонки, веб-камера, флэш-память, наушники.
5. а, г, д, е;

Уровень C.

1. D:\HOME\HELP\readme.txt;
2. Ване не стоит брать диски 2 и 3, т.к.:
-второй диск имеет частоту 2ГГц, превышающая тактовую частоту компьютера;
-третий диск имеет больший объем ОП, чем его компьютер.
deniskotvitsky56
Перевод в 2-ричную систему счисления
алгоритм, правило или просто мои проверенные познания: делим число из десятичной системы на 2 потом записываем частное и запоминаем для дальнейшего выведения остатка , если при делении делимое иррациональное то мы отнимаем 1 от делимого и делим на 2, при выведении остатка с рациональным числом мы просто вычитаем их и получаем остаток 0, но при выведении остатка с иррациональным числом мы берём обычное иррациональное уменьшаемое и рациональное вычитаемое (то есть  отнимаем 1 от делимого которое в данном случае является уменьшаемым) и при таком раскладе остаток будет 1.
то есть если число рациональное то остаток = 0 но если оно  иррациональное то остаток = 1 

296₁₀ : 2 = 148₁₀
296₁₀ - 296₁₀ = 0 (остаток 0)
148₁₀ : 2 = 74₁₀ 
148₁₀ - 148₁₀ = 0 (остаток 0)
74₁₀ : 2 = 37₁₀
74₁₀ - 74₁₀ = 0 (остаток 0)
37₁₀ : 2  = 16₁₀
37₁₀ - 36₁₀ = 1 (остаток 1)
18₁₀ : 2 = 8₁₀
18₁₀ - 18₁₀ = 0 (остаток 0)
9₁₀ : 2 = 4₁₀
9₁₀ - 8₁₀ = 1 (остаток 1)
4₁₀ : 2 = 2₁₀
4₁₀ - 4₁₀ = 0 (остаток 0)
2₁₀ : 2 = 1₁₀
2₁₀ - 2₁₀ = 0 (остаток 0)
1₁₀ : 2 = 0₁₀ 
1₁₀ - 0₁₀ = 1 (остаток 1)

пересчитываем в строчку от меньшего к большему то есть от 1 до 296 остатки : 100101000₂

Оформление 

296₁₀ = 100101000₂
проверка:
296₁₀ : 2 = 148₁₀
296₁₀ - 296₁₀ = 0 (остаток 0)
148₁₀ : 2 = 74₁₀ 
148₁₀ - 148₁₀ = 0 (остаток 0)
74₁₀ : 2 = 37₁₀
74₁₀ - 74₁₀ = 0 (остаток 0)
37₁₀ : 2  = 16₁₀
37₁₀ - 36₁₀ = 1 (остаток 1)
18₁₀ : 2 = 8₁₀
18₁₀ - 18₁₀ = 0 (остаток 0)
9₁₀ : 2 = 4₁₀
9₁₀ - 8₁₀ = 1 (остаток 1)
4₁₀ : 2 = 2₁₀
4₁₀ - 4₁₀ = 0 (остаток 0)
2₁₀ : 2 = 1₁₀
2₁₀ - 2₁₀ = 0 (остаток 0)
1₁₀ : 2 = 0₁₀ 
1₁₀ - 0₁₀ = 1 (остаток 1)

прости но я потратил много времени что бы сформулировать правило ну и проверка это самое лёгкое что казалось, остальное всё исходит из 2-ричной системы счисления.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужна ваша решение на языке паскаль На обработку поступает натуральное число, не превышающее 10^9. Нужно написать программу, которая выводит на экран сумму нечетных цифр числа, которые делятся на 3. Если в числе нет таких цифр, требуется на экран вывести «NO».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

EkaterinaSEMENOV702
Барскова1943
len4ik1986
lechocolat
troyasport
tooltechnic
Zhilinoe134
rimmaskis
myhauz
natakrechko
olgavbaranova
baranovaas
Алина1564
АндреевичОльга641
Vladimirovna Viktorovna