Точно должно работать для PascalABC.Net (версия 3.2, сборка 1341). program Task; var N,i,kol,sum:integer; //По-хорошему, не integer. Потому что мы работаем с натуральными числами, а не отрицательными begin read(N); for i:=1 to N do begin if (i mod 15)=0 then kol:=kol+1; //15 - это НОК(3,5) end; while (N<>0) do begin sum:=sum+N mod 10; N:=N div 10; end; writeln('Количество чисел, делящихся и на 3, и на 5, равно ',kol); writeln('Сумма цифр числа N равна', sum); end.
Пиши, если что-то не работает или не понятно :)
Cannabikh
27.12.2021
//PascalABC.NET версия 3.2, сборка 1389 //Если программа не запускается, то обновите версию type s_b = record s_d: array[1..31, 0..9]of integer; s_o: array [0..9] of string; d_m: array [1..31] of byte; end;
var r, d: s_b;
begin r.s_o[0] := 'еда'; r.s_o[1] := 'zilie'; r.s_o[2] := 'oby4'; d.s_o[1] := 'myz'; d.s_o[2] := 'zina'; for var a := 1 to 31 do for var b := 0 to 9 do begin r.s_d[a, b] := 0; r.d_m[a] := a; d.s_d[a, b] := 0; d.d_m[a] := a; end;
Println(r); Println(d); end.
покороче, убрано лишнее
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу: заполнить массив случайными целыми числами, в котором 15 элементов. На языке паскаля
program Task;
var N,i,kol,sum:integer; //По-хорошему, не integer. Потому что мы работаем с натуральными числами, а не отрицательными
begin
read(N);
for i:=1 to N do
begin
if (i mod 15)=0 then kol:=kol+1; //15 - это НОК(3,5)
end;
while (N<>0) do
begin
sum:=sum+N mod 10;
N:=N div 10;
end;
writeln('Количество чисел, делящихся и на 3, и на 5, равно ',kol);
writeln('Сумма цифр числа N равна', sum);
end.
Пиши, если что-то не работает или не понятно :)