kolesnikovaen
?>

Питон , 3-5. Изменение списка гостей: вы только что узнали, что один из гостей прийти не сможет, поэтому вам придется разослать новые приглашения. Отсутствующего гостя нужно заменить кем-то другим.• Начните с программы из упражнения 3-4. Добавьте в конец программы команду print для вывода имени гостя, который прийти не сможет.• Измените список и замените имя гостя, который прийти не сможет, именем нового приглашенного.• Выведите новый набор сообщений с приглашениями – по одному для каждого участника, входящего в список.3-6. Больше гостей: вы решили купить обеденный стол большего размера. Дополнительные места позволяют пригласить на обед еще трех гостей.• Начните с программы из упражнения 3-4 или 3-5. Добавьте в конец программы команду print, которая выводит сообщение о расширении списка гостей.• Добавьте вызов insert() для добавления одного гостя в начало списка.• Добавьте вызов insert() для добавления одного гостя в середину списка.• Добавьте вызов append() для добавления одного гостя в конец списка.• Выведите новый набор сообщений с приглашениями – по одному для каждого участника, входящего в список.

Информатика

Ответы

borodin

1. На ленте машины Тьюринга содержится последовательностью символов “+”. Напишите программу для машины Тьюринга, которая каждый второй символ “+” заменит на “–”. Замена начинается с правого конца последовательности. Автомат в состоянии q1 обозревает один из символов указанной последовательности. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

2. Дано число n в восьмеричной системе счисления. Разработать машину Тьюринга, которая увеличивала бы заданное число n на 1. Автомат в состоянии q1 обозревает некую цифру входного слова. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

3. Дана десятичная запись натурального числа n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

4. Дано натуральное число n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1, при этом в выходном слове старшая цифра не должна быть 0. Например, если входным словом было “100”, то выходным словом должно быть “99”, а не “099”. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

5. Дан массив из открывающих и закрывающих скобок. Построить машину Тьюринга, которая удаляла бы пары взаимных скобок, т.е. расположенных подряд “( )”.

Например, дано “) ( ( ) ( ( )”, надо получить “) . . . ( ( ”.

Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

6. Дана строка из букв “a” и “b”. Разработать машину Тьюринга, которая переместит все буквы “a” в левую, а буквы “b” — в правую части строки. Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

askorikova

#include <iostream>

using namespace std;

class Building {

private:

 string adress_m;

 int storeyCount_m;

 bool quarantine_m;

public:

 Building(string adress = "", int count = -1) {

  adress_m = adress;

  storeyCount_m = count;

 }

 void addStoreys(int count) {

  storeyCount_m += count;

 }

 void quarantineOn() {

  cout << "Quarantine: on";

  cout << endl;

  quarantine_m = 1;

 }

 void quarantineOff() {

  cout << "Quarantine: off";

  cout << endl;

  quarantine_m = 0;

 }

 void quarantineCheck() {

  cout << "Quarantine: ";

  if(quarantine_m) {

   cout << "on";

   cout << endl;

  } else {

   cout << "off";

   cout << endl;

  }

 }

 string getAdress() {

  return adress_m;

 }

 int getStorey() {

  return storeyCount_m;

 }

};

int main() {

Building build("dirt house", 1);

cout << build.getAdress() << " " << build.getStorey() << " storeys" << " " << endl;

build.quarantineCheck();

build.quarantineOn();

build.addStoreys(2);

cout << build.getAdress() << " " << build.getStorey() << " storeys" << " " << endl;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Питон , 3-5. Изменение списка гостей: вы только что узнали, что один из гостей прийти не сможет, поэтому вам придется разослать новые приглашения. Отсутствующего гостя нужно заменить кем-то другим.• Начните с программы из упражнения 3-4. Добавьте в конец программы команду print для вывода имени гостя, который прийти не сможет.• Измените список и замените имя гостя, который прийти не сможет, именем нового приглашенного.• Выведите новый набор сообщений с приглашениями – по одному для каждого участника, входящего в список.3-6. Больше гостей: вы решили купить обеденный стол большего размера. Дополнительные места позволяют пригласить на обед еще трех гостей.• Начните с программы из упражнения 3-4 или 3-5. Добавьте в конец программы команду print, которая выводит сообщение о расширении списка гостей.• Добавьте вызов insert() для добавления одного гостя в начало списка.• Добавьте вызов insert() для добавления одного гостя в середину списка.• Добавьте вызов append() для добавления одного гостя в конец списка.• Выведите новый набор сообщений с приглашениями – по одному для каждого участника, входящего в список.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

delfinmos
Андрей
ccc712835
Денис_Петровна
Galina-3639220565
andre6807
Avetisyan575
yakushkinayuliya
Tatianamir765654
АлександрАлександровна
ЮрьевичКарпова1564
orantus3
Исакова-Александрович511
Amelin-Alipova
len22
▲