Espivak
?>

Составьте программу на языке BASIC. 1. Высчитать площадь трапеции если известны высота, верхнее основание и разность между основаниями. 2. Компьютер здоровается с человеком, узнает его имя и. обращаясь по имени, сообщает, что сегодня - выходной. 3. Вычислить площадь треугольника по трем сторонам (формула Герона 4. Вычислить время падения кирпича в секундах с крыши дома, если известны высота дома в метрах и, ускорение свободного падения

Информатика

Ответы

saniopt

number = 4222

count = 0

number = str(number)  

number = list(number)

number = map(int, number)

for i in number:

   if i % 2 != 0:

       count += 1

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

number = 4222

count = 0

( c комментариями)

number = str(number)

number = list(number)

number = map(int, number)

# переводим число в список

for i in number:

   if i % 2 != 0:

       count += 1

#находим нечетное число

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

# выводим его

Talikova164
3,7,9
37,93,79
973,979,373
Вообще говоря это зависит от формулировки "используя цифры". Из задания непонятно, использовать нужно ВСЕ цифры, или достаточно использования любых из них. Если под словом "используя" понимать, что можно использовать только эти цифры, но при этом использовать все не обязательно, то можно записать 77 и 999.
Всего трёхзначных чисел из цифр 3,7,9 можно записать 3*3*3 (по три возможных цифры на каждую позицию - если цифры на позициях могут повторяться. и 3*3*1, если не могут повторяться.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке BASIC. 1. Высчитать площадь трапеции если известны высота, верхнее основание и разность между основаниями. 2. Компьютер здоровается с человеком, узнает его имя и. обращаясь по имени, сообщает, что сегодня - выходной. 3. Вычислить площадь треугольника по трем сторонам (формула Герона 4. Вычислить время падения кирпича в секундах с крыши дома, если известны высота дома в метрах и, ускорение свободного падения
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lanabogd
Georgievich-Zamudinovna2003
Yevgenii1423
A2017
dakimov
faberlic0168
НиколаевнаФ
iv1as2
Viktorovich
алексей-Ветошкин
Почему 2 в 14 степине равен 16384
Alekseevich1012
abdulhakovalily22
ilplakhotin8734
d892644813661946
sashakrav