yuda12
?>

Напишите программу на паскале, которая находит все минимумы и максимумы функции (см. варианты на следующей странице) на интервале [-5;5] с точностью 0, 001, используя метод «золотого сечения». Границы интервала для поиска каждого минимума и максимума определяются автоматически.

Информатика

Ответы

Maria095096

  начало

                                                  делим на 2

                          есть остаток                               нет остатка

                          возводим в куб                         возводим в кводрат

                                                    конец        

krisrespect2
Замечание. Так как количество вводимых чисел заранее не известно, то откроем бесконечный цикл со всегда верным условием True, но как только будет введено число 0, остановим цикл командой break.

Программа:

program z;
var k,s,x:integer;
begin
k:=0;              {начальное значение количества двузначных чисел}
s:=0;              {начальное значение суммы двузначных чисел}
while True do  {открываем бесконечный цикл}
begin
readln(x);        {вводим число х}
if x=0 then break;  {если введенное число равно 0, то остановить цикл}
if (x>9)and(x<100) then  {если число двузначное, т.е. от 10 до 99} 
    begin 
    k:=k+1;         {количество увеличиваем на 1}
    s:=s+x;         {увеличиваем предыдущее значение суммы на число х}
    end;
end;
if k=0 then writeln('NO')  {если двузначных чисел не было, то вывод NO}
   else writeln(s/k);          {иначе вывод ср.арифметического}
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале, которая находит все минимумы и максимумы функции (см. варианты на следующей странице) на интервале [-5;5] с точностью 0, 001, используя метод «золотого сечения». Границы интервала для поиска каждого минимума и максимума определяются автоматически.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

amarantmetall
НиканоровСалиев675
seletan1
kazanoop
krylova-natali
nusupova
gilmore886173
alex091177443
moskvichkabakery56
kengyra
groomingprofi56
olarina6510
buslavgroupe
fedserv
Сергеевна_Юрикович