znaberd786
?>

Напишите программу на языке С ++ по следующему алгоритму ​

Информатика

Ответы

tatyana58
1)  there  are  4  rooms  in  this  house.  (подставите  количество  сами,  т.к.  не  вижу  в  каком  2)there  are  2  bedrooms  in  this  house. 3) there    in  his  living  (аналогично  на  остальные  вопросы),  т.к.  не  видно  картинки,  чтобы  вам    перечислить,что  в  зале,  в  обеденной  комнате,  ванне,  спальне  и  ученическом  столе).
natkoff5
Var used: Set of Char;
    s1, s2: string;
    i: integer;
    done: boolean;
    c: char;

function IsLetter(c: char): boolean;
begin
  IsLetter := ((c >= 'a') and (c <= 'z')) or ((c >= 'A') and (c <= 'Z'));
end;

function UpperCase(c: char): char;
begin
  if (c >= 'a') and (c <= 'z') then
    UpperCase := Chr(Ord(c) - Ord('a') + Ord('A'))
  else
    UpperCase := c;
end;

begin
used := [];

readln(s1);
readln(s2);

for i := 1 to length(s1) do
  if (IsLetter(s1[i])) then
    include(used, UpperCase(s1[i]));

for i := 1 to length(s2) do
  if (IsLetter(s2[i])) then
    include(used, UpperCase(s2[i]));

done := False;
for c := 'A' to 'Z' do
  if not (c in used) then
  begin
    done := True;
    write(c);
  end;

if not done then
  write(0);

writeln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке С ++ по следующему алгоритму ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gurman171
Goldaram84
borzhemskaya19823110
platonovkosty
VadimovnaIgor
yuliyastatsenko3894
Segyn1218
superkiosk249
Olga1233
marinakovyakhova
vladimirdoguzov
TrubnikovKlimenok926
Eduardovich_Sergei1062
Голосова-Лобанов1555
losevev5619