akopsiroyan
?>

Напишите программу на Python по следующему алгоритму: алг сумма вещь a, s нач s:=0; a:=1; нц пока a<=10 s:=s+a a:=a+1 кц вывод s кон как можно скорее!

Информатика

Ответы

diana0720

s = 0

a = 1

while a <= 10:

   s += a

   a += 1

print(s)

Вывод: 55

Vladimirovna Dmitrieva
1 Задача
1) Начало
2) i = 1
2.1) K = i^2
2.2) Вывод K
2.3) i = i + 1
2.4) i > 5 ?
Если Да, возвращаемся на 2.1)
Если Нет, окончание цикла.
3) Конец.

2 Задача
1) Начало
2) k = 0 (счетчик нечетных чисел)
3) Ввод первого числа A1
3.1) Если [A1 / 2] < A1 / 2, то k = k + 1 (ввели нечетное число)
4) Ввод второго числа A2
4.1) Если [A2 / 2] < A2 / 2, то k = k + 1 (ввели нечетное число)
5) Ввод третьего числа A3
5.1) Если [A3 / 2] < A3 / 2, то k = k + 1 (ввели нечетное число)
6) Вывод k
7) Конец

3 Задача
1) Начало
2) Объявление массива А() пока неизвестного размера (динамического)
3) i = 1
3.1) Ввод очередного числа A(i)
3.2) Если A(i) = 0, то переход на 4)
3.3) i = i + 1
3.4) Возврат на 3.1)
4) Переопределение динамического массива A(i) размером i элементов.
5) Конец
YuRII1236
Var
a:array[1..10] of integer;
cnt1, cnt2, i:integer;
begin
 For i:= 1 to 10 do
   Read(a[i]);
 for i:= 1 to 5 do
  if a[i] > 0 then cnt1 := cnt1 + 1;
 for i:= 6 to 10 do
  if a[i] > 0 then cnt2 := cnt2 + 1;
 if cnt1 = cnt2 then Writeln('Количество пол-х элементов одинаково');
 if cnt1 > cnt2 then Writeln('Количество пол-х элементов больше в первой половине');
 if cnt1 < cnt2 then  Writeln('Количество пол-х элементов больше во второй половине');
end.

Пример:

-1 -2 3 5 0 4 6 7 -2 -5
Количество пол-х элементов больше во второй половине

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на Python по следующему алгоритму: алг сумма вещь a, s нач s:=0; a:=1; нц пока a<=10 s:=s+a a:=a+1 кц вывод s кон как можно скорее!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Шаленко
mrropevvv
chuykin
jablokov
mrropevvv
ogonizoloto
Anshel2018534
kosstroy
premiumoft
kronid12
julichca68
margarita25061961
gennadevna
Svetlana395
spodobnyi