Var M: array[1..32767] of real; Min: real; N, i: integer; Begin Write('N = ');ReadLn(N); if (N <= 0) then WriteLn('Количество элементов должно быть положительно') else begin Write('Введите элементы массива в количестве ',N,' штук'); For i:= 1 to N do Read(M[i]); Min := M[1]; For i:= 2 to N do if (M[i] < Min) then Min := M[i]; WriteLn; Write('Получившийся массив:'); For i:= 1 to N do begin M[i] := M[i] / Min; Write(' ',M[i]); end; end End.
<script> function DeShifr() { let Text = document.getElementById("shifr").value; let L = Text.length; let NeChet = Text.substr(0,L/2+L%2); let Chet = Text.substr(L/2+L%2,L/2); let DeShifr = ""; for (let i = 0, c = 0, n = 0; i < L; i++) { DeShifr += (i%2?Chet[c++]:NeChet[n++]); } document.getElementById("DeShifr").innerHTML = DeShifr; } </script> </head> <body> <form> <label for="shifr">Введите зашифрованный тест сообщения:</label> <textarea id="shifr"></textarea> <button type="button" onCLick="DeShifr()">Расшифровать</button> <div id="DeShifr"></div> </form> </body> </html>
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу для вычисления суммы всех четных чисел от 6 до 36 паскаль
var i, s: integer;
begin
s:=0;
for i:=6 to 36 do
if (i mod 2 = 0) then s:=s+i;
end;