Larisaodinets5
?>

Напишите программу, которая вычисляет сумму всех чисел кратных 5, записанных в файле в столбик, и выводит результат в другой файл (Pascal)

Информатика

Ответы

druzhbamagazin2457

ответ:калькулятор

Объяснение:

Забиваешь в инете калькулятор и ищешь тот который тебе подходит.

Karlova1507
:D 
Ну го Ничего если  на паскале напишу ? 
uses crt;
var  a:array[1..50] of integer ;i,j,n,x,t,k:integer;b:string;
begin
read(n);     
for i:= 1 to n do     
begin     
a[i]:=random(15);     
write(a[i],' ');     
end;     
writeln;     
for i:= 1 to n-1 do     
for j:= i+1 to n do     
if a[i]> a[j] then begin t:=a[i]; a[i]:=a[j]; a[j]:=t; end;     
for i:= 1 to n do     
write(a[i],' ');     
writeln;     
read(x);     
for i:= 1 to n do     
 if a[i] = x then k:=k+1;     
 str(k,b);     
n:=length(b);     
 if k in  [11..19] then write (k,' раз') else     
 if k = 0 then  write('число ',x,' не встречается ')else     
case b[n] of     
 '0','1','5','6','7','8','9': write (k,' раз');     
 '3','4','2': write (k,' раза') ;     
end;
end.
gavrilasmax05
:D 
Ну го Ничего если  на паскале напишу ? 
uses crt;
var  a:array[1..50] of integer ;i,j,n,x,t,k:integer;b:string;
begin
read(n);     
for i:= 1 to n do     
begin     
a[i]:=random(15);     
write(a[i],' ');     
end;     
writeln;     
for i:= 1 to n-1 do     
for j:= i+1 to n do     
if a[i]> a[j] then begin t:=a[i]; a[i]:=a[j]; a[j]:=t; end;     
for i:= 1 to n do     
write(a[i],' ');     
writeln;     
read(x);     
for i:= 1 to n do     
 if a[i] = x then k:=k+1;     
 str(k,b);     
n:=length(b);     
 if k in  [11..19] then write (k,' раз') else     
 if k = 0 then  write('число ',x,' не встречается ')else     
case b[n] of     
 '0','1','5','6','7','8','9': write (k,' раз');     
 '3','4','2': write (k,' раза') ;     
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вычисляет сумму всех чисел кратных 5, записанных в файле в столбик, и выводит результат в другой файл (Pascal)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Давид-Ольга
Nikita
Lenuschakova1982316
xsmall1
boro-1973
info2990
Lapushkina
manager9
BelozerovaGeller648
KonovalovKonstantinovna1306
Valerevna Tuzova
bike-garage8
iraimironova
mgrunova3966
catsk8
▲