latoyan817
?>

1) Составить программу на языке Паскаль, которая запрашивает числа а, в, с и находит значение d по формуле d=b2-4ac. 2) Составить программу на языке Паскаль, которая находит площадь треугольника по трем сторонам а, в, с, которые запрашиваются с клавиатуры ИНФАРМАТИКА​

Информатика

Ответы

Kozloff-ra20146795

Информация - это любые сведения, принимаемые и передаваемые, сохраняемые различными источниками. Информация - это вся совокупность сведений об окружающем нас мире, о всевозможных протекающих в нем процессах, которые могут быть восприняты живыми организмами, электронными машинами и другими информационными системами.

Первоначально сведения получают при органов чувств – зрения, слуха, обоняния, вкуса и осязания. Для передачи информации на ближнем расстоянии существует язык, который позволяет сообщить полученные сведения другому человеку. Кроме того, передать что-либо другому человеку можно, написав письмо либо в процессе спектакля, а также при разговоре по телефону. Несмотря на то, что в последнем примере используется средство связи, то есть промежуточное устройство, оно позволяет передать сведения в непосредственном контакте.

Для передачи данных от человека к компьютеру необходимо введение ее в память устройства. Информация может иметь разный вид, о чем будет идти разговор далее.

Передача от компьютера к компьютеру происходит посредством промежуточных устройств (флеш-карты, интернета, диска и т. д.).

#телефон, компьютер и тд

baumanec199613
Решение на паскаль.
начало решения задач одинаковое, а дальше см. внизу

program xxx;
var b: array [1..6, 1..6] of integer;
 i, j, s : integer;
begin
for i:= 1 to 6 do
for j:=1 to 6 do
 b[i,j]:= random(131)-65;
writeln ('исходная матрица В:');
for i:=1 to 6 do
  begin
   for j:=1 to 6 do
     write (b[i,j]:4);
   writeln
 end;

задание 1.
s:=0;
for i:= 1 to 6  do
  if b[i,3]>0 then s:=s+b[i,3];
writeln ('сумма положительных элементов 3-го столбца', s)
end.

задание 2.
i:=2;
while i<=6 do begin
  for j:= 1 to 6 do
    if b[i,j]<0 then b[i,j]:=0;
  i:=i+2
end;
writeln ('полученная матрица В:');
for i:=1 to 6 do
  begin
   for j:=1 to 6 do
     write (b[i,j]:4);
   writeln
 end
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Составить программу на языке Паскаль, которая запрашивает числа а, в, с и находит значение d по формуле d=b2-4ac. 2) Составить программу на языке Паскаль, которая находит площадь треугольника по трем сторонам а, в, с, которые запрашиваются с клавиатуры ИНФАРМАТИКА​
Ваше имя (никнейм)*
Email*
Комментарий*