Дмитрий192
?>

Составить программу решения следующей задачи. С первой яблони сорвали 3 яблока, со второй – 6 яблок, с третьей – 12 яблок и т.д., и наконец с последней – 48 яблока. Сколько яблок сорвали со всех яблонь?

Информатика

Ответы

Vladimirovna1370

Program n_1;

var i, b, k:integer; a: array [1..2000] of integer;

begin

   writeln('Введите числа');

   for i:=1 to 2000 do read(a[i]);

   writeln;

   writeln ('Числа, состоящие из 2 разрядов:');

   for i:=1 to 2000 do begin

       b:=a[i];

       k:=0;

       while b>0 do

           begin

           b:=b div 10;

           k:=k+1;

       end;

       if k=2 then write(a[i], ' ');

   end;

   writeln;

   writeln ('Числа, состоящие из 3 разрядов и кратные 3:');

   for i:=1 to 2000 do begin

       b:=a[i];

       k:=0;

       while b>0 do

           begin

           b:=b div 10;

           k:=k+1;

       end;

       if k=3 then begin

           b:=(a[i] mod 10) + ((a[i] div 10) mod 10) + ((a[i] div 100) mod 10);

           if (b mod 3) = 0 then write(a[i], ' ');

       end;

   end;

end.

olma-nn477

1) 255₁₀ = 11111111₂

2) 255₁₀ = 377₈

3) 255₁₀ = FF₁₆

4) 397₁₀ = 110001101₂

5) 397₁₀ = 615₈

6) 397₁₀ = 18D₁₆

Объяснение:

1) 255₁₀ = 11111111₂

255 / 2 = 127 + остаток 1

127 / 2 = 63 + остаток 1

63 / 2 = 31 + остаток 1

31 / 2 = 15 + остаток 1

15 / 2 = 7 + остаток 1

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

11111111₂ = 1 * 2⁰ + 1 * 2¹ + 1 * 2² + 1 * 2³ + 1 * 2⁴ + 1 * 2⁵ + 1 * 2⁶ + 1 * 2⁷ = 1 + 2 + 4 + 8 + 16 + 32 + 64 + 128 = 255₁₀

2) 255₁₀ = 377₈

255 / 8 = 31 + остаток 7

31 / 8 = 3 + остаток 7

3 / 8 = 0 + остаток 3

записываем остатки снизу вверх

377₈  = 7 * 8⁰ + 7 * 8¹ + 3 * 8² = 7 + 56 + 192 = 255₁₀

3) 255₁₀ = FF₁₆

255 / 16 = 15 + остаток 15

15 / 16 = 0 + остаток 15

записываем остатки снизу вверх

FF₁₆  = F * 16⁰ + F * 16¹ = 15 + 240 = 255₁₀

4) 397₁₀ = 110001101₂

397 / 2 = 198 + остаток 1

198 / 2 = 99 + остаток 0

99 / 2 = 49 + остаток 1

49 / 2 = 24 + остаток 1

24 / 2 = 12 + остаток 0

12 / 2 = 6 + остаток 0

6 / 2 = 3 + остаток 0

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

110001101₂  = 1 * 2⁰ + 0 * 2¹ + 1 * 2² + 1 * 2³ + 0 * 2⁴ + 0 * 2⁵ + 0 * 2⁶ + 1 * 2⁷ + 1 * 2⁸ = 1 + 4 + 8 + 128 + 256 = 397₁₀

5) 397₁₀ = 615₈

397 / 8 = 49 + остаток 5

49 / 8 = 6 + остаток 1

6 / 8 = 0 + остаток 6

записываем остатки снизу вверх

615₈  = 5 * 8⁰ + 1 * 8¹ + 6 * 8² = 5 + 8 + 384 = 397₁₀

6) 397₁₀ = 18D₁₆

397 / 16 = 24 + остаток 13

24 / 16 = 1 + остаток 8

1 / 16 = 0 + остаток 1

записываем остатки снизу вверх

18D₁₆  = D * 16⁰ + 8 * 16¹ + 1 * 16² = 13 + 128 + 256 = 397₁₀

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу решения следующей задачи. С первой яблони сорвали 3 яблока, со второй – 6 яблок, с третьей – 12 яблок и т.д., и наконец с последней – 48 яблока. Сколько яблок сорвали со всех яблонь?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ramzaev09
Matveevanastya0170
irinabaranova2760
selena77
Budanov317
info36
fixer2006
akakne86
alina-bas
izumrud153
filippovev1
Boldinova-Marianna
bagrjashv41
Сорокина
tteplovoz3789
▲