pimenovamar
?>

Написать программу, которая сравнивает два целых числа и выводит на экран наибольшее.

Информатика

Ответы

bureiko
1. В приведенном коде ошибка. Не хватает ";" в третьей строке снизу.
2. Немного изменим ваш код и получим искомое значение x
Искомое число х = 16293

var
  x, y, a, b, k: integer;

begin
  k:=10000;
  repeat
    x:=k;
    a := 0; b := 0; y := 1;
    while x > 0 do
    begin
      if (x mod 10) mod 2 = 0
        then
        a := a * 10 + x mod 10
      else begin
        y := y * 10;
        b := b * 10 + x mod 10
      end;
      x := x div 10
    end;
    a := a * y + b;
    k := k + 1;
    until a = 26391;
    writeln(a:8, k-1:8); 
end.

 
albina6580
Уровни — это инструмент, который Photoshop и другие программы редактирования изображений предоставляют для сдвига или растягивания уровней яркости в гистограмме изображения. Уровни дают возможность скорректировать яркость, контраст и диапазон цвета, задавая положения абсолютно чёрного, абсолютно белого и полутонов на гистограмме. Поскольку гистограмма любой фотографии уникальна, не существует единого коррекции уровней для всех ваших фотографий. Понимание принципов, согласно которым корректируются уровни на гистограмме изображения вам лучше передать тона в итоговом изображении.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая сравнивает два целых числа и выводит на экран наибольшее.
Ваше имя (никнейм)*
Email*
Комментарий*
▲