lawyer-2019
?>

Написать программы, но обязательно проверить на разных числах в https://pythontutor.ru 1.Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны 2. Ввести два числа. Если их сумма больше 100, то сумму уменьшить в 2 раза, в противном случае увеличить в 2 раза.

Информатика

Ответы

rinata542

На python:

a = 0  #Например

b = 3

c = 0

while a == b and b == c and c == a:

    print(a, b, c)

if a == b and b == c or c == a:

   print(a, b)

else:

  print("Нечего не совпадает")

Объяснение:

Грудинин604

Program YouName;

Var i,n:Integer;

s: array[0..75] of Integer; // Объявление массива

Begin

write('Введите количество элементов массива: ');

readln(n); // Ввод кол-ва элементов массива

writeln('');

writeln('Исходный массив:');

for i:=1 to n do // Перебор от первого до n элементов массива

 Begin

  // Если используете паскаль ABC, то можно написать так: s[i]:=random(-100,100);

  s[i]:=random(100-(-100)+1)+(-100); // Заполнение элементов массива от -100 до 100.

  write(s[i], '(', i, ')',' '); // Вывод элемента массива с его порядковым номером

 End;

writeln;

writeln('');

writeln('Видоизмененный массив:');

for i:=1 to n do // Перебор от первого до n элементов массива

 Begin

  If (i mod 2 = 0) and (s[i] mod 2 = 0) then // Если элемент и значение массива четное, то..

   Begin

    s[i]:=s[i]*(-1); // Смена знака на противоположный

    write(s[i], '(', i, ')',' '); // Вывод элемента массива с его порядковым номером

   End;

 End;

writeln;

writeln('');

End.

Объяснение: Если есть вопросы, то пишите мне в лс.

vfif-804828
Вариант 1
var  str:string;
  A,B,i:integer;
 begin
   write('введите ваш текст');
   readln(str);
   for i:=1 to length(str) do begin
     if (str[i]='А')or (str[i]='а') then a:=a+1;
     if (str[i]='Б')or (str[i]='б') then B:=b+1;
   end;
   if (A+B)=0 then write('нет таких букв') else write ('A= ',A,' Б= ',b);
end.

вариант 3
var  str:string;
  A,B,i:integer;
 begin
   write('введите ваш текст');
   readln(str);
   i:=1;
   while i<=length(str) do begin
    if (str[i]='А')or (str[i]='а') then delete(str,i,1);
    i:=i+1;
    end;
   write(str);
      end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программы, но обязательно проверить на разных числах в https://pythontutor.ru 1.Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны 2. Ввести два числа. Если их сумма больше 100, то сумму уменьшить в 2 раза, в противном случае увеличить в 2 раза.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nikitamihailov22095010
sve-lysenko
anazarov80
Исмагилова_Саният
Lomakina-Valerievna1779
maxchuev
apromovich1
mikhisakov2017
mirdetzhuk79
Andreevich
nestruev
ninaandreeva3179
chuev4444
krasnova1977
nord0764