sdy19576216
?>

Составить программу на языке Паскаль. Ввести массив из 12 целых чисел. Вставить в него число В перед последним элементом. Число В ввести случайным образом. Полученный массив вывести на экран.

Информатика

Ответы

sve707ta

1) Program Massiv1;

    Uses Crt;

    var k:array[1..12] of real;

           i,c:integer;

begin

     clrscr;    

     write('Введите элементы массива k:');

     c:=0;   

     for i:=1 to 12 do

        begin 

            readln(k[i]);

            if (k[i]<0) then Inc(c);

 

     end;

 

   writeln;

    writeln;  

 for i:=1 to 12 do write(k[i]:4:4);

 writeln;  

  writeln('Количество элементов <0:',c); 

  readkey;      

end.   

 

 

 

2) Program Massiv2;

    Uses Crt;

    var m:array[1..10] of integer;

         i,c:integer;

begin

     clrscr;    

     write('Введите элементы массива m:');

     c:=0;   

     for i:=1 to 10 do

        begin 

            readln(m[i]);

            if (m[i]=3) then Inc(c);

     end;

   writeln;

    writeln;  

 for i:=1 to 12 do write(m[i]:4);

 writeln;  

  writeln('Количество элементов =3:',c); 

  readkey;      

end.   

 

В третьем задании  видимо имеется ввиду номер элемента этого массива, т.к по условию задачи массив у нас один.

 

 

 3) Program Massiv3;

    Uses Crt;

    var m:array[1..8] of integer;

           i,c,max:integer;

begin

     clrscr;    

     write('Введите элементы массива m:');

     c:=0;   

     for i:=1 to 8 do  readln(m[i]);

   writeln;

   writeln;  

 max:=m[1] 

 for i:=1 to 8 do

   begin

        if  (m[i]>max) then

                    begin

                         max:=m[i];

                         c:=i 

                   end;        

        write(m[i]:4); 

end;

  writeln('Индекс максимального элемента =:',c); 

  readkey;      

end.   

 

4) Program Massiv4;

    Uses Crt;

    var m:array[1..12] of integer;

           i,c,max,sum:integer;

begin

     clrscr;    

     write('Введите элементы массива m:');

     c:=0; sum:=0;   

     for i:=1 to 12 do  readln(m[i]);

   writeln;

   writeln;  

 max:=m[1] 

 for i:=1 to 12 do

   begin

        if  (m[i]>max) then

                    begin

                         max:=m[i];

                         c:=i 

                   end;        

        write(m[i]:4);  

end;

for i:=1 to c-1 do sum:=sum+m[i];

 writeln('Количество элементов расположенных до max :',с-1); 

 writeln('Сумма элементов расположенных до max :',sum); 

 readkey;      

end.   

 

 В пятом задании  видимо имеется ввиду значения элементов массива меньшие чем сумма первого и последнего

 

 

 

5) Program Massiv5;

    Uses Crt;

    var k:array[1..15] of real;

           sum:real;

           i,c:integer;

begin

     clrscr;    

     write('Введите элементы массива k:');

     c:=0;   

     for i:=1 to 15 do   readln(k[i]);

  sum:=k[1]+k[15];       

   writeln;

   writeln;  

 for i:=1 to 15 do

     begin

          write(k[i]:4:4);

           if  (k[i]<sum) tnen Inc(c); 

         end;

 writeln;  

  writeln('Количество элементов :',c); 

  readkey;      

end.   

vintazhvintazh90

Уақыт — өлшемдер жүйесінің оқиғаларды реттеу, олардың ұзақтығын және араларындағы интервалдарын сипаттауда, және нәрселердің қозғалысын сипаттауда пайдаланатын маңызды мүшесі. Уақыт мифология, философия және ғылымның әр салада пайдалану үшін қарама-қайшылысыз сипаттау, зерттеу нысаны болып, талай-талай ұлы ғалымдарды өмірге әкелген.[1]

Уақыт - оқиғаның ұзақтығы және тізбектілігін сипаттайтын физиканың негізгі түсініктерінің бірі.[2]

Физика мен басқа ғылымдарда уақыт іргелі өлшем болып табылады, яғни ол басқа өлшемдер арқылы өрнектелмейді, себебі басқалары — жылдамдық, күш, қуат сияқты өздері іргелі өлшемдермен өрнектеледі (атап айтқанда бұл жағдайда — уақыт, әрі кеңістік деп аталатын келесі іргелі өлшемдермен). Ғылымда керектігі, әрі мүмкіндігі — өлшем үшін пайдаланатын және таңдалынып алынған өлшем бірлігі бар уақыт — операциялық анықтамасы қолданылады. Философтар арасында екі түрлі уақытқа деген көзқарас бар. Біріншісіне сәйкес уақыт — ғалам құрылымының іргелі бөлігі, оқиғалардың қатар-қатар жүруінің өлшемі. Бұл сэр Исаак Ньютон жататын реалистік көзқарас, сондықтан бұны Ньютондық уақыт деп те атайды. Бұған қарсы көзқарасқа сәйкес уақыт — адамзат соның көмегімен оқиғаларды реттеп, салыстыратын, интеллектуалды құрылымның (кеңістіктік пен сандармен қатар) іргелі мүшесі. Готфрид Лейбниц пен Иммануил Кант дәстүрі болатын осы екінші көзқарасқа сәйкес уақыт «арқылы өтетін» «ағатын» затқа жатпайды, немесе оқиғаларға ыдыс бола алмайды, және өзі өлшене алмайды.

Технологтар мен ғалымдар мезгілдік уақыт өлшеумен айналысқан, және астрономияның негізгі зерттеу нысаны болған. Периодты оқиғалар мен периодты қозғалыстар уақыт өлшем бірлік стандарты ретінде ұзақ уақыт пайдалылып келеді. Мысалы, күннің аспан бойымен қозғалысы, маятник тербелісі, айдың фазалары және жүрек дүрсілі. Уақыттың әлеуметік маңызы да зор (“уақыт – ақша”), ол адамның күнделікті уақыттың шектеулілігін сезінуі мен адам өмірінің шектеулілілігі

Daulyatyanov1266
//Dev-C++ 4.9.9.2

#include <iostream>
#include <ctime>
using namespace std;

int main(){
    srand(time(NULL));
    int ma[5][10];
    int maxn=0;
    double s=0;
    double max=-2147483647;
    for(int i=0;i<10;i++)
     for(int j=0;j<5;j++)
      ma[i][j]=rand()%2;
    for(int j=0;j<5;j++){
     for(int i=0;i<10;i++)
      s=s+ma[i][j];
     if(s>max){max=s; maxn=j;}
     s=0;}
    cout<<"Matrix"<<endl;
    for(int i=0;i<10;i++){
     for(int j=0;j<5;j++)
      cout<<ma[i][j]<<" ";
     cout<<endl;}
    cout<<maxn+1;
    cin.get();
    cin.get();
  return 0;
    }

Нужна ! ( программа с++) с датчика случайных чисел заполнить двоичную матрицу 5х10. определить номер

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке Паскаль. Ввести массив из 12 целых чисел. Вставить в него число В перед последним элементом. Число В ввести случайным образом. Полученный массив вывести на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ynikolaev2657
moonligh3560
mir5552
Vos-sv
vik1223
sanseth5
annakuzina2023
Dimston134877
narkimry134
sakalrip
yurkovam-037
pelagia-kola2658
skryabinamaria
uchpapt
kate281078
▲