euzdenova
?>

Оформляем на листах А4 (от руки или на компьютере Первый лист – титульный. Проект, включает в себя следующие пункты: 1. Условие задачи 2. Блок-схема задачи 3. Программа, записанная на языке Паскаль 4. Таблицу из трех тестирующих примеров Пояснение Тестирующий пример — это набор входных данных, заданных пользователем для проверки работо алгоритма. При проверке разветвляющихся алгоритмов необходимо в качестве входных данных задать такие величины, чтобы охватить все возможные варианты. Например, для программы y:=0; If x>0 then y:=x+1 else y:=x Необходимо предусмотреть входные данные, исходя их условия х>0 Возможны 3 варианта: х — положительное, х — отрицательное, х=0 Следовательно, можно взять следующие тестирующие входные данные. х= –1 (отрицательное), х=0, х=5 Тогда после выполнения программы увидим при x= –1 y= –1; при x=0 y=1; при x=5 y=6 это и есть тестирующие примеры. Нужно решить эту задачу Напишите программу-модель анализа пожарного датчика в помещении, которая выводит сообщение «Пожарная ситуация», если температура (ее значение вводится с клавиатуры) в комнате превысила 60 ºС

Информатика

Ответы

mos197653

Переведем  ip-адреса в двоичную систему:

121.171.5.70 =  01111001.10101011.00000101.01000110

121.171.5.107 = 01111001.10101011.00000101.01101011

По условию адреса находятся в одной сети, то есть смотрим совпадающие биты ( выделены жирным).

Получается адрес сети:

01111001.10101011.00000101.01000000

А маска :

11111111.11111111.11111111.11000000

Нам надо найти наименьшее количество адресов, то есть попробуем изменить маску, добавив один бит: 11111111.11111111.11111111.11100000

Применив поразрядную конъюнкцию вычисляем адрес сети для обоих адресов:

01111001.10101011.00000101.01000000

01111001.10101011.00000101.01100000

Как видим адреса сетей разные, что не соответствует условию задачи.

Поэтому подходящая маска для наименьшего количества адресов:

11111111.11111111.11111111.11000000

количество возможных адресов: 2⁶ = 64

ответ: 64

tatry2005

Объяснение:

C++Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

 

void main()

{

   setlocale(0, "rus");

   int mas[5][5];

   srand(time(NULL));

   cout << "Первоначальный массив" << endl;

   for (int i = 0; i<5; i++){

       cout << endl;

       for (int j = 0; j<5; j++){

           mas[i][j] = rand() % 10;

           cout << mas[i][j] << " ";

       }

       cout << endl;

}

   

   cout << "Полученный массив" << endl;

   for (int i = 0; i<5; i++){

       int tmp = mas[i][i];

       mas[i][i] = mas[i][5 - i - 1];

       mas[i][5 - i - 1] = tmp;

   }

   cout << endl;

   for (int i = 0; i<5; i++){

       cout << endl;

       for (int j = 0; j<5; j++){

           cout << mas[i][j] << " ";

       }

       cout << endl;

   }

}

0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Оформляем на листах А4 (от руки или на компьютере Первый лист – титульный. Проект, включает в себя следующие пункты: 1. Условие задачи 2. Блок-схема задачи 3. Программа, записанная на языке Паскаль 4. Таблицу из трех тестирующих примеров Пояснение Тестирующий пример — это набор входных данных, заданных пользователем для проверки работо алгоритма. При проверке разветвляющихся алгоритмов необходимо в качестве входных данных задать такие величины, чтобы охватить все возможные варианты. Например, для программы y:=0; If x>0 then y:=x+1 else y:=x Необходимо предусмотреть входные данные, исходя их условия х>0 Возможны 3 варианта: х — положительное, х — отрицательное, х=0 Следовательно, можно взять следующие тестирующие входные данные. х= –1 (отрицательное), х=0, х=5 Тогда после выполнения программы увидим при x= –1 y= –1; при x=0 y=1; при x=5 y=6 это и есть тестирующие примеры. Нужно решить эту задачу Напишите программу-модель анализа пожарного датчика в помещении, которая выводит сообщение «Пожарная ситуация», если температура (ее значение вводится с клавиатуры) в комнате превысила 60 ºС
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zimin1111
puchkovajulia
Кристина Валентиновна
nailya-abdulova25
Natalya1895
lenalevmax7937
jamaltreid
kmb1960679
is0019
николаевич-Елена988
ainud
kep92
langprint
sdvigov
jnrhjq3597
▲