Vasilevich
?>

ОЧЕНЬ Написать программу С++ для решения задачи: В парке начали красить скамейки. В первый день покрасили B скамеек. Во второй покрасили A% от общего количества скамеек. Осталось покрасить 45 скамеек. Сколько всего скамеек в парке.

Информатика

Ответы

Artak96993298
Леона́рд Э́йлер (нем. Leonhard Euler; 15 апреля 1707, Базель, Швейцария — 7 (18) сентября 1783, Санкт-Петербург, Российская империя) — швейцарский, немецкий и российский математик и механик, внёсший фундаментальный вклад в развитие этих наук (а также физики, астрономии и ряда прикладных наук)[7]. Эйлер — автор более чем 850 работ[8] (включая два десятка фундаментальных монографий) по математическому анализу, дифференциальной геометрии, теории чисел, приближённым вычислениям, небесной механике, математической физике, оптике,  , кораблестроению, теории музыки и другим областям[9][10]. Он глубоко изучал медицину, химию, ботанику, воздухоплавание, теорию музыки, множество европейских и древних языков. Академик Петербургской, Берлинской, Туринской, Лиссабонской и Базельской академий наук, иностранный член Парижской академии наук[11].
vladusha47713
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var x:=ReadInteger('Введите число:');
  var (i,y):=(2,BigInteger(x));
  while true do begin
    y*=x;
    Writeln(x,'^',i,'=',y);
    i+=1
    end
end.

Пример
Введите число: 2
2^2=4
2^3=8
2^4=16
2^5=32
2^6=64
2^7=128
2^8=256
2^9=512
2^10=1024
2^11=2048
2^12=4096
2^13=8192
2^14=16384
2^15=32768
2^16=65536
2^17=131072
2^18=262144
2^19=524288
2^20=1048576
2^21=2097152
2^22=4194304
2^23=8388608
2^24=16777216
2^25=33554432
2^26=67108864
2^27=134217728
2^28=268435456
2^29=536870912
2^30=1073741824

2^64=18446744073709551616
2^65=36893488147419103232
2^66=73786976294838206464
2^67=147573952589676412928
2^68=295147905179352825856
2^69=590295810358705651712
2^70=1180591620717411303424

2^200=1606938044258990275541962092341162602522202993782792835301376
2^201=3213876088517980551083924184682325205044405987565585670602752
2^202=6427752177035961102167848369364650410088811975131171341205504
2^203=12855504354071922204335696738729300820177623950262342682411008
2^204=25711008708143844408671393477458601640355247900524685364822016
2^205=51422017416287688817342786954917203280710495801049370729644032
2^206=102844034832575377634685573909834406561420991602098741459288064
2^207=205688069665150755269371147819668813122841983204197482918576128
2^208=411376139330301510538742295639337626245683966408394965837152256
2^209=822752278660603021077484591278675252491367932816789931674304512
2^210=1645504557321206042154969182557350504982735865633579863348609024

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ОЧЕНЬ Написать программу С++ для решения задачи: В парке начали красить скамейки. В первый день покрасили B скамеек. Во второй покрасили A% от общего количества скамеек. Осталось покрасить 45 скамеек. Сколько всего скамеек в парке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

АртакСергеевич1723
karkh267
Андрей_Станиславовна
Amulenkov
nikolai37
mbobo28311
Сергеевна-С.А.1549
Теплова
vladburakoff5
Милита1065
olegtarasov1965
gigbes
Sokolova-Shcherbakov
siger06297
bellaalya13862